summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-25 12:30:39 +0000
committerSam James <sam@gentoo.org>2021-05-25 12:32:29 +0000
commitc1580432a0c4c95856fba8c1e1217a913a2ec73e (patch)
treed35466a66998568e6addb726082e76f4be77922f /sci-libs
parentdev-util/pkgdev: add 0.1.4 (diff)
downloadgentoo-c1580432a0c4c95856fba8c1e1217a913a2ec73e.tar.gz
gentoo-c1580432a0c4c95856fba8c1e1217a913a2ec73e.tar.bz2
gentoo-c1580432a0c4c95856fba8c1e1217a913a2ec73e.zip
sci-libs/libqalculate: add 3.19.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-3.19.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index 331080f759d9..9dfedbd163ac 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1,2 +1,3 @@
DIST libqalculate-3.17.0.tar.gz 1770500 BLAKE2B 247c74db32e63437c556dd60f00f56acf53d9ba90ea1027b34b98b455215e6c03e3ee34116b6d3989fa43b449e18b6f2ebaed67f9dff36f08dd8b38c685c6586 SHA512 b204dc44b6fdb2b72d3c85840fee38482db071f0f8241420ea24093dcdcc377c66f516c571827fbede40237618a53153a75bb7afee7f3bee7a1a71aedd779a11
DIST libqalculate-3.18.0.tar.gz 1788899 BLAKE2B 7701dab4d11c9d54f95454cd7be530cfa9f5a8dbe438dac6d734c294ce1eb5be1f4fdb30ef6d041d19f389df88dce4fa7dea68d555ad441992498685bfb3b919 SHA512 37d870f6fd147745747ac971758a512e85e33c42605b99ac4ba68b53ca42a6f0da7ede3869fe3ea4e47d77961e826ad999e0f0c0d87039042563f124bea1250e
+DIST libqalculate-3.19.0.tar.gz 2007385 BLAKE2B bd0b1bbfcd4bad0053ec9193bec1081cce609935b4282add885d7277a20696cc3c69272b8255d9da3e79907ec4c57b4b87c971908fc3da890d46ff4849e65ccc SHA512 19df6e46e88478df4dd7ae592557c8c984f76c137708892b01f88737c2a8d72ca01324fd1b1322069292795cd158483b3fc0cc99c6559279e7a2f76ca4a47a56
diff --git a/sci-libs/libqalculate/libqalculate-3.19.0.ebuild b/sci-libs/libqalculate/libqalculate-3.19.0.ebuild
new file mode 100644
index 000000000000..4f0fc4d23f9f
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-3.19.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/21"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ # Needed for po-defs/Makefile
+ export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
+ export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"
+
+ econf \
+ --disable-static \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}