summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-15 15:16:29 +0000
committerBenda Xu <heroxbd@gentoo.org>2020-11-09 22:01:45 +0800
commitc86bb949ca134f8c656ab572e107fbca127ae010 (patch)
treed147e00e9e842183b4629e55ff7b9b512562cf4d /sci-libs
parentsci-libs/scikits_learn: version bump to 0.23.2 (diff)
downloadgentoo-c86bb949ca134f8c656ab572e107fbca127ae010.tar.gz
gentoo-c86bb949ca134f8c656ab572e107fbca127ae010.tar.bz2
gentoo-c86bb949ca134f8c656ab572e107fbca127ae010.zip
dev-python/scikit-learn: moved sci-libs/scikits_learn
Cancel the previous move in 2Q2020. Closes: https://bugs.gentoo.org/665482 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scikits_learn/Manifest2
-rw-r--r--sci-libs/scikits_learn/metadata.xml17
-rw-r--r--sci-libs/scikits_learn/scikits_learn-0.22.2_p1-r1.ebuild73
-rw-r--r--sci-libs/scikits_learn/scikits_learn-0.23.2.ebuild70
4 files changed, 0 insertions, 162 deletions
diff --git a/sci-libs/scikits_learn/Manifest b/sci-libs/scikits_learn/Manifest
deleted file mode 100644
index d89024ada31d..000000000000
--- a/sci-libs/scikits_learn/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST scikits_learn-0.22.2_p1.tar.gz 7034850 BLAKE2B 41c362ef6594e837a9fc798837e666fbb51e33954fdf700292650204fd9d1ab4fc4d1695890d02a24ad68f4dcc2d3cde8f0827eca70c6fb9a6f0e5c0d9c04fd5 SHA512 20bcda5c65f76bce9b71c5b5fb1b499f7f3a7a3f6fa5fade80a38dc658cb434e16e9d5a4906a9657157a5cc90a6d51080575d6e510207baa9f8b06c4fa761d5b
-DIST scikits_learn-0.23.2.tar.gz 7190564 BLAKE2B db90e3d05d9b563c6cd98a6820c27b541e757e3fb6c25262b720842811b9e26d41a4a9c1d73e675714573d84dab799a0c450e768f4a41a39a6a61f6930c4c79a SHA512 e9797185b1b9def3ee5525e9b72742784aeb78fe8b069bb5aeab1d0f4513cf738c4489ed894274606dea9d6a32ccd3df26170ce1951e443dc77f9287c372e8c5
diff --git a/sci-libs/scikits_learn/metadata.xml b/sci-libs/scikits_learn/metadata.xml
deleted file mode 100644
index 0f62a4aec772..000000000000
--- a/sci-libs/scikits_learn/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- scikits.learn is a python library for machine learning. It aims to
- implement classic machine learning algorithms while remaining simple
- and efficient.
- </longdescription>
- <upstream>
- <remote-id type="pypi">scikit-learn</remote-id>
- <remote-id type="sourceforge">scikit-learn</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/scikits_learn/scikits_learn-0.22.2_p1-r1.ebuild b/sci-libs/scikits_learn/scikits_learn-0.22.2_p1-r1.ebuild
deleted file mode 100644
index d191b819ec3c..000000000000
--- a/sci-libs/scikits_learn/scikits_learn-0.22.2_p1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-MY_PV="${PV//_p/.post}"
-MY_PN="${PN//s_/-}"
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/
- https://github.com/scikit-learn/scikit-learn"
-SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-#ffhttps://github.com/scikit-learn/scikit-learn/archive/0.22.2.post1.tar.gz
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- virtual/blas:=
- virtual/cblas:=
-"
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -rf sklearn/src || die "failed to remove bundled cblas"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- pushd "${TEST_DIR}/lib" >/dev/null || die
- pytest -vv || die "testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
-}
diff --git a/sci-libs/scikits_learn/scikits_learn-0.23.2.ebuild b/sci-libs/scikits_learn/scikits_learn-0.23.2.ebuild
deleted file mode 100644
index 55d42a949aa2..000000000000
--- a/sci-libs/scikits_learn/scikits_learn-0.23.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/
- https://github.com/scikit-learn/scikit-learn"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-S="${WORKDIR}/scikit-learn-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-RDEPEND="
- ${DEPEND}
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # scikits-learn now uses the horrible numpy.distutils automagic
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
-
- # remove bundled cblas
- rm -rf sklearn/src || die "failed to remove bundled cblas"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- pushd "${TEST_DIR}/lib" >/dev/null || die
- pytest -vv || die "testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- fi
-
-}