summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-12-09 15:13:43 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-12-09 15:26:07 -0500
commitdce36de55ade7598eaddbeb2047bea53a498056a (patch)
tree7b68a2187a6d42d13cac001ebcf5e46aa3f27ad1 /sci-libs
parentsci-libs/geos: Bump (diff)
downloadgentoo-dce36de55ade7598eaddbeb2047bea53a498056a.tar.gz
gentoo-dce36de55ade7598eaddbeb2047bea53a498056a.tar.bz2
gentoo-dce36de55ade7598eaddbeb2047bea53a498056a.zip
sci-libs/cddlib: new upstream version 0.94m.
This version moves the header files to a soon-to-be-standard location (so that Debian, Fedora, et cetera don't all have to move them) and is going to break some consumers as a result. For that reason, I opted not to package the previous version right away. This version, however, contains a critical bug fix as well. So users need the option to upgrade. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cddlib/cddlib-094m.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/cddlib/cddlib-094m.ebuild b/sci-libs/cddlib/cddlib-094m.ebuild
new file mode 100644
index 000000000000..73468ab72e6d
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094m.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This should have been dealt with versionator in the direction
+# 0.94x -> 094x - now we are screwed.
+MY_PV="0.94j"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="C library implementing the Double Description Method"
+HOMEPAGE="https://www.inf.ethz.ch/personal/fukudak/cdd_home/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs tools"
+
+DEPEND="dev-libs/gmp:0"
+RDEPEND="dev-libs/gmp:0="
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use tools; then
+ rm "${ED}"/usr/bin/* || die
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ # Nobody wants the dvi/ps manual...
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.{dvi,ps} || die
+
+ # since the PDF manual is installed by default.
+ if ! use doc; then
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.pdf || die
+ fi
+
+ # The docs and examples are *both* installed by default, so we
+ # have to remove the examples if the user doesn't want them.
+ docompress -x "/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d}
+ if ! use examples; then
+ rm -r "${ED}/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d} || die
+ fi
+}