summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 02:44:42 +0000
committerSam James <sam@gentoo.org>2021-03-27 02:57:42 +0000
commite7d8d47775417633390dca1416eac0e0e09441d6 (patch)
tree0bf5846d1ef9c70d506dddc1732feb86ecd902ae /sci-libs
parentsci-libs/hypre: drop useless cmake.eclass inherit in 2.18.2 (diff)
downloadgentoo-e7d8d47775417633390dca1416eac0e0e09441d6.tar.gz
gentoo-e7d8d47775417633390dca1416eac0e0e09441d6.tar.bz2
gentoo-e7d8d47775417633390dca1416eac0e0e09441d6.zip
sci-libs/hypre: add 2.20.0
Closes: https://bugs.gentoo.org/681580 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hypre/Manifest1
-rw-r--r--sci-libs/hypre/hypre-2.20.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-libs/hypre/Manifest b/sci-libs/hypre/Manifest
index fc080f5581bf..427470deb4ad 100644
--- a/sci-libs/hypre/Manifest
+++ b/sci-libs/hypre/Manifest
@@ -1 +1,2 @@
DIST hypre-2.18.2.tar.gz 5699792 BLAKE2B 6adb343d23594adea60a4009f589285236365a5769b1d5cb66908ce83984dd48b3be929e6c7298c7b9cb1e2d67b1fe7ea641c8a160562d223edb9809977fb684 SHA512 7b343a5c8530d7f5e31cad6c940c2f154b2b954566d4fe8525d690fec41db23936a46fb642a994791de32984e696c624804fb1fde1f0c9ce026f1a6e46b9c0f4
+DIST hypre-2.20.0.tar.gz 5971556 BLAKE2B 63cef33913f1f4c569c396dd18227ae4346807e659306521e9340789944e22dc70be3b9baec7fb1385f562b53045e5c87fcad604aa242a941199ff9fe0a0c21d SHA512 842868b494960506fa3df4e72abb42084d701ec14305f9b040b9dcb578b4bbdaa8afb079057a7e53ad721b440c72ee804775c3b8319f2d01a2f281920a9cd350
diff --git a/sci-libs/hypre/hypre-2.20.0.ebuild b/sci-libs/hypre/hypre-2.20.0.ebuild
new file mode 100644
index 000000000000..12b7b63fb7e6
--- /dev/null
+++ b/sci-libs/hypre/hypre-2.20.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2 toolchain-funcs flag-o-matic
+
+DESCRIPTION="Parallel matrix preconditioners library"
+HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
+SRC_URI="https://github.com/${PN}-space/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug examples fortran int64 openmp mpi"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ sci-libs/superlu:=
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG COPYRIGHT README )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc* ]] ; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp ; then
+ ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # link with system superlu and propagate LDFLAGS
+ sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
+ -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
+ -i src/config/Makefile.config.in || die
+
+ sed -e '/HYPRE_ARCH/s: = :=:g' \
+ -i src/configure || die
+
+ # link with system blas and lapack
+ sed -e '/^BLASFILES/d' \
+ -e '/^LAPACKFILES/d' \
+ -i src/lib/Makefile || die
+}
+
+src_configure() {
+ tc-export CC CXX
+ append-flags -Dhypre_dgesvd=dgesvd_
+
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] ; then
+ append-flags -fopenmp && append-ldflags -fopenmp
+ fi
+
+ if use mpi ; then
+ CC=mpicc
+ FC=mpif77
+ CXX=mpicxx
+ fi
+
+ cd src || die
+
+ # without-superlu: means do not use bundled one
+ econf \
+ --enable-shared \
+ --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
+ --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
+ --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
+ --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
+ --with-timing \
+ --without-superlu \
+ $(use_enable debug) \
+ $(use_enable openmp hopscotch) \
+ $(use_enable int64 bigint) \
+ $(use_enable fortran) \
+ $(use_with openmp) \
+ $(use_with mpi MPI)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
+ PATH="${S}/src/test:${PATH}" \
+ emake -C src check
+}
+
+src_install() {
+ emake -C src install \
+ HYPRE_INSTALL_DIR="${ED}" \
+ HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
+ HYPRE_INC_INSTALL="${ED}/usr/include/hypre"
+
+ if use examples; then
+ dodoc -r src/examples
+ fi
+}