summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-04 13:04:54 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:06:20 +0000
commitebe0c3520fbbeca0405b4e99050f28e32dad0949 (patch)
tree3cd48e14b256953887bdb6185a802e1abc209176 /sci-libs
parentsci-calculators/qalculate-gtk: Remove old 3.16.0 (diff)
downloadgentoo-ebe0c3520fbbeca0405b4e99050f28e32dad0949.tar.gz
gentoo-ebe0c3520fbbeca0405b4e99050f28e32dad0949.tar.bz2
gentoo-ebe0c3520fbbeca0405b4e99050f28e32dad0949.zip
sci-libs/matio: Bump to 1.5.21
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/20684 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/Manifest1
-rw-r--r--sci-libs/matio/matio-1.5.21.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index 28cc71e850f5..88be2ff82c96 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -1 +1,2 @@
DIST matio-1.5.19.tar.gz 10108869 BLAKE2B db641bda8d68e203af765aa83ecf661e011995e242c4f91aacb4bcc8ba2b545c36a3eec3f4954b3d7ecc286e630acd15b34ec48b372063bfb8b892259fc49ec7 SHA512 c087944a7d87d78a7de662d7e19f5f81c55858cf5bf315c28d5a0f7544555b0816045e20bb0c83752eb3d54b589d9237a27cf3de98e3ebefcc7ea0af9311740e
+DIST matio-1.5.21.tar.gz 10110430 BLAKE2B 1c43d44e69b28eacd9cc672a393df6a55c4ea0e06334eace9058b45bb0bd1582d43cafd30ad121bad33ad29dda52d5259be8c38f6cbacdb05a47da3644dfb984 SHA512 b00bcad807e6a7e10afa656eb77a0e3e9fb08d9cecc3e94ba41ef91ce60367d6686e6d387a874bbb83eb2f895d4a97caac554a70e7f5f6f5cb750052702d411c
diff --git a/sci-libs/matio/matio-1.5.21.ebuild b/sci-libs/matio/matio-1.5.21.ebuild
new file mode 100644
index 000000000000..adb63f7b65e3
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.21.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="https://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/11" # subslot = soname version
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc test/test*.c
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+
+ # no static archives
+ find "${ED}" -name "*.la" -delete || die
+}