summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-11 22:26:53 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-12 20:59:26 +0200
commitf15208d661780f73287e71d2f22b3b4f5f699bf1 (patch)
tree1eebde1317f1ec336bf575641516b4c68dbdec9e /sci-libs
parentsci-libs/shapely: switched maintainership (diff)
downloadgentoo-f15208d661780f73287e71d2f22b3b4f5f699bf1.tar.gz
gentoo-f15208d661780f73287e71d2f22b3b4f5f699bf1.tar.bz2
gentoo-f15208d661780f73287e71d2f22b3b4f5f699bf1.zip
sci-libs/shapely: moved from sci-libs/Shapely
Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapely/Manifest (renamed from sci-libs/Shapely/Manifest)2
-rw-r--r--sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch (renamed from sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch)0
-rw-r--r--sci-libs/shapely/metadata.xml (renamed from sci-libs/Shapely/metadata.xml)0
-rw-r--r--sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild (renamed from sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild)12
-rw-r--r--sci-libs/shapely/shapely-1.7.0.ebuild (renamed from sci-libs/Shapely/Shapely-1.7.0.ebuild)5
5 files changed, 13 insertions, 6 deletions
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/shapely/Manifest
index 4fab9715505e..d2eb3633fd23 100644
--- a/sci-libs/Shapely/Manifest
+++ b/sci-libs/shapely/Manifest
@@ -1,2 +1,2 @@
DIST Shapely-1.6.4.post2.tar.gz 225745 BLAKE2B 96e995db6dd1464bac7c2562efdc7f298a5f23c388e44f334db685b1cfa1025ff403db870e11328977a267483726504e03b6d7c47fe4234a3a5966a13b2b7311 SHA512 027c816ef2104f654569ca658b52b87c60e5ba6a45927fcc51c23dd1922f3f9f7fdcea3601160b0a999e39611617142833ccac790777093be8b96a0d9083f78f
-DIST Shapely-1.7.0.tar.gz 281419 BLAKE2B 1a4e84104f21d2f5a5eb810883a89deb20fd47cf146efed884994786364b29bb5a194b063a50ae21842c07c335cbbee0c3d1a1e4ff4e43e0d083080fe33815ac SHA512 4d944fc6727e11d004ef7ba0325c159aa5ae03043f17b029ab0a399d6dcd361c4d299ad864a045a99b0229e333d5b42634bc6fd1ed94b914b7cf58fb886af2de
+DIST shapely-1.7.0.tar.gz 281419 BLAKE2B 1a4e84104f21d2f5a5eb810883a89deb20fd47cf146efed884994786364b29bb5a194b063a50ae21842c07c335cbbee0c3d1a1e4ff4e43e0d083080fe33815ac SHA512 4d944fc6727e11d004ef7ba0325c159aa5ae03043f17b029ab0a399d6dcd361c4d299ad864a045a99b0229e333d5b42634bc6fd1ed94b914b7cf58fb886af2de
diff --git a/sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch b/sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch
index a9213a333765..a9213a333765 100644
--- a/sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch
+++ b/sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch
diff --git a/sci-libs/Shapely/metadata.xml b/sci-libs/shapely/metadata.xml
index c23d0b5a4d40..c23d0b5a4d40 100644
--- a/sci-libs/Shapely/metadata.xml
+++ b/sci-libs/shapely/metadata.xml
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild b/sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild
index a9ad4b613f26..be793427c4b7 100644
--- a/sci-libs/Shapely/Shapely-1.6.4_p2-r1.ebuild
+++ b/sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild
@@ -3,6 +3,10 @@
EAPI=7
+MY_PN="Shapely"
+MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
+MY_P="${MY_PN}-${MY_PV}"
+
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -10,14 +14,12 @@ inherit distutils-r1
DESCRIPTION="Geometric objects, predicates, and operations"
HOMEPAGE="https://pypi.org/project/Shapely/"
-MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
-
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+ EGIT_REPO_URI="https://github.com/Toblerity/${MY_PN}.git"
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+ SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}.tar.gz"
KEYWORDS="amd64 ~arm64 x86"
fi
@@ -36,7 +38,7 @@ RESTRICT="!test? ( test )"
PATCHES=( "${FILESDIR}/${P}-test_operations.patch" ) # bug 701624
-S="${WORKDIR}/${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
python_prepare_all() {
# fix install path for Cython definition file
diff --git a/sci-libs/Shapely/Shapely-1.7.0.ebuild b/sci-libs/shapely/shapely-1.7.0.ebuild
index a9bd484c2d61..3e2d10095cec 100644
--- a/sci-libs/Shapely/Shapely-1.7.0.ebuild
+++ b/sci-libs/shapely/shapely-1.7.0.ebuild
@@ -3,6 +3,9 @@
EAPI=7
+MY_PN="Shapely"
+MY_P="${MY_PN}-${PV}"
+
PYTHON_COMPAT=( python3_{7..8} )
inherit distutils-r1
@@ -24,6 +27,8 @@ BDEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
"
+S="${WORKDIR}/${MY_P}"
+
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/matplotlib