summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-12 16:18:54 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-12 16:31:29 -0400
commitf22acba679894d575d5910eb0ee80009434f1dcb (patch)
tree3631866d3b64aa77544c5bdf40b8c6fcc8c17a5b /sci-libs
parentnet-misc/openssh: work around Clang 15 miscompilation with -fzero-call-used-r... (diff)
downloadgentoo-f22acba679894d575d5910eb0ee80009434f1dcb.tar.gz
gentoo-f22acba679894d575d5910eb0ee80009434f1dcb.tar.bz2
gentoo-f22acba679894d575d5910eb0ee80009434f1dcb.zip
sci-libs/nlopt: drop 2.6.2-r1, 2.7.1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/Manifest1
-rw-r--r--sci-libs/nlopt/nlopt-2.6.2-r1.ebuild109
-rw-r--r--sci-libs/nlopt/nlopt-2.7.1.ebuild97
3 files changed, 0 insertions, 207 deletions
diff --git a/sci-libs/nlopt/Manifest b/sci-libs/nlopt/Manifest
index bc0bc63e1b06..91292448e091 100644
--- a/sci-libs/nlopt/Manifest
+++ b/sci-libs/nlopt/Manifest
@@ -1,2 +1 @@
-DIST nlopt-2.6.2.tar.gz 2040229 BLAKE2B f1f4124de574600ddbef8a885bbdd3a4f57b469b2f958ce94bbc831cf9bfa8a845e438fccfe4ab219a73a5675b8d880f6d49e0e7cbe9d0966777b0d2344521d4 SHA512 61e5c01140a57c0ad2a0acd82ad50dce1b5679dc281e55cbbc332e876b19a689013100617545a42b721d8c487df37d6ccd67859171243433fe29468f259b556b
DIST nlopt-2.7.1.tar.gz 2044180 BLAKE2B 6d459f94a26ee6dd7f72c73c48992bd047150aa525bc4ad088c8516127afc5c7843f6fbb6726c2f845271b87934c13e0892a063362ab50df51f92e81979111fb SHA512 e23cb522fc696010574c14b72be85acc0f8ccf0bf208bf2b8789c57d6c5a6e6d419ee10330581518b1c1567018ae909b626ce7761d4fbd5bf112916871e420e2
diff --git a/sci-libs/nlopt/nlopt-2.6.2-r1.ebuild b/sci-libs/nlopt/nlopt-2.6.2-r1.ebuild
deleted file mode 100644
index 01368b67d508..000000000000
--- a/sci-libs/nlopt/nlopt-2.6.2-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit python-r1 cmake fortran-2
-
-DESCRIPTION="Non-linear optimization library"
-HOMEPAGE="https://ab-initio.mit.edu/nlopt/"
-SRC_URI="https://github.com/stevengj/nlopt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1 MIT"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="cxx guile octave python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- guile? ( dev-scheme/guile:* )
- octave? ( sci-mathematics/octave )
- python? (
- ${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- "
-DEPEND="
- ${RDEPEND}
- python? ( dev-lang/swig )
- "
-
-src_prepare() {
- cmake_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNLOPT_CXX=$(usex cxx)
- -DNLOPT_FORTRAN=$(usex test)
- -DNLOPT_GUILE=$(usex guile)
- -DNLOPT_OCTAVE=$(usex octave)
- -DNLOPT_PYTHON=$(usex python)
- -DNLOPT_SWIG=$(usex python)
- -DNLOPT_TESTS=$(usex test)
- )
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_configure
- else
- cmake_src_configure
- fi
- if use static-libs; then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- )
- BUILD_DIR="${S}_static-libs" run_in_build_dir cmake_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_compile
- else
- cmake_src_compile
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir cmake_src_compile
- fi
-}
-
-src_test() {
- do_test() {
- local a f
- cd "${BUILD_DIR}"/test
- for a in {1..$(usex cxx 9 7)}; do
- for f in {5..9}; do
- ./testopt -a $a -o $f || die "algorithm $a function $f failed"
- done
- done
- }
- if use python; then
- python_foreach_impl run_in_build_dir do_test
- else
- do_test
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir do_test
- fi
-}
-
-nlopt_install() {
- cmake_src_install
- python_optimize
-}
-
-src_install() {
- if use python; then
- python_foreach_impl run_in_build_dir nlopt_install
- else
- cmake_src_install
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir dolib.a libnlopt.a
- fi
- local r
- for r in */README; do newdoc ${r} README.$(dirname ${r}); done
-}
diff --git a/sci-libs/nlopt/nlopt-2.7.1.ebuild b/sci-libs/nlopt/nlopt-2.7.1.ebuild
deleted file mode 100644
index 10e6b998d4e3..000000000000
--- a/sci-libs/nlopt/nlopt-2.7.1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit python-r1 cmake fortran-2
-
-DESCRIPTION="Non-linear optimization library"
-HOMEPAGE="https://github.com/stevengj/nlopt"
-SRC_URI="https://github.com/stevengj/nlopt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1 MIT"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="cxx guile octave python test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- guile? ( dev-scheme/guile:* )
- octave? ( >=sci-mathematics/octave-6 )
- python? (
- ${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- "
-DEPEND="
- ${RDEPEND}
- python? ( dev-lang/swig )
- "
-
-src_prepare() {
- cmake_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- # MATLAB detection causes problems (as in bug 826774) if we don't
- # explicitly disable it.
- local mycmakeargs=(
- -DNLOPT_CXX=$(usex cxx)
- -DNLOPT_FORTRAN=$(usex test)
- -DNLOPT_GUILE=$(usex guile)
- -DNLOPT_OCTAVE=$(usex octave)
- -DNLOPT_MATLAB=OFF
- -DNLOPT_PYTHON=$(usex python)
- -DNLOPT_SWIG=$(usex python)
- -DNLOPT_TESTS=$(usex test)
- )
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_configure
- else
- cmake_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_compile
- else
- cmake_src_compile
- fi
-}
-
-src_test() {
- do_test() {
- local a f
- cd "${BUILD_DIR}"/test
- for a in {1..$(usex cxx 9 7)}; do
- for f in {5..9}; do
- ./testopt -a $a -o $f || die "algorithm $a function $f failed"
- done
- done
- }
- if use python; then
- python_foreach_impl run_in_build_dir do_test
- else
- do_test
- fi
-}
-
-nlopt_install() {
- cmake_src_install
- python_optimize
-}
-
-src_install() {
- if use python; then
- python_foreach_impl run_in_build_dir nlopt_install
- else
- cmake_src_install
- fi
- local r
- for r in */README; do newdoc ${r} README.$(dirname ${r}); done
-}