summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-25 19:09:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-25 19:10:05 +0100
commitf7fa28854faef51e8d66fdf1c51395752a285640 (patch)
tree2150fa502c3bea5704262ff19264c8e26dea6f60 /sci-libs
parentnet-firewall/firehol - cleanup (diff)
downloadgentoo-f7fa28854faef51e8d66fdf1c51395752a285640.tar.gz
gentoo-f7fa28854faef51e8d66fdf1c51395752a285640.tar.bz2
gentoo-f7fa28854faef51e8d66fdf1c51395752a285640.zip
sci-libs/scipy: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/Manifest3
-rw-r--r--sci-libs/scipy/scipy-0.16.1.ebuild143
2 files changed, 146 insertions, 0 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 53817b256160..0b3e52981326 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -2,3 +2,6 @@ DIST scipy-0.15.1-html.zip 24956050 SHA256 c27d3656ffed1b988890cf192c692f646b00d
DIST scipy-0.15.1-ref.pdf 18313446 SHA256 d96046ddbc91383fb37e3ae2bbdc6945e0c2fc70fa230e0bcda0789e6025ca7e SHA512 9ca6a656e454058273f5153d84acbca42f4ea9b99d0dbfde4a019cbb3ef7e87c4068660bc787506ca749024d45efaea7254614486d56b114c762fc8a69c3b496 WHIRLPOOL b907a6011671b0e0919d48b3e4587fd09cad3f2b463a302e1c9be22facec5f2d599b1eb9497a0cf1e3a0125b3beda0b1e00e7ca2cd40453c49a2df368b9c794e
DIST scipy-0.15.1.tar.gz 11401878 SHA256 a212cbc3b79e9a563aa45fc5c517b3499198bd7eb7e7be1e047568a5f48c259a SHA512 fff4412d850c431a1b4e6ee3b17958ee5ab3beb81e6cb8a8e7d56d368751eaa8781d7c3e69d932dc002d718fddc66a72098acfe74cfe29ec80b24e6736317275 WHIRLPOOL 31f2f6ca33be1945bedf41f84cf62831c9b22f4d7079d2b0b7b21706b17eb4ab5f3a948be645bcb86a35f3a714e4f277bd66261d02d20d8aeb5077b2095c952f
DIST scipy-0.16.0.tar.gz 18137295 SHA256 92592f40097098f3fdbe7f5855d535b29bb16719c2bb59c728bce5e7a28790e0 SHA512 943f21a2798db124b7e1fb9257064b725702cc6656a90ae10dda285c36166c378304c7d44a571b5ab4ef6819e995ea42e947417e16b2a665dd6db4a460adbd89 WHIRLPOOL ba99d1ea46522814e9181c8991cede8b8a8f4a00b39d3fffc5fa570a52d4ef57044e9af4bb37ea24e733ec6af226e2787a4e88360c53d7bd67a505446725c62f
+DIST scipy-0.16.1-html.zip 33158474 SHA256 4183a170f10537f343b0bb6d77abb3c8a6abc3ebfb7e36d90713d852f1e3e5c5 SHA512 47b1ebd43b58ada7f4fd772e2a94c25d8ee2b03d808743ac386c7fbcc8a1daa3082906156ba421b1dd91ce2fb4f0114639ea124caac7522d919507029fee6c1a WHIRLPOOL 5289e9ebf32be6ea9c75c022913bcf303743efc3ad010a394c186ea9ecf1f0155ce658b6595d264531c46d27b4e7a9d760ab906698cd18e5fae9c123f08494d2
+DIST scipy-0.16.1-ref.pdf 33916573 SHA256 4fb994f7706142bb519183bbeca665422b68bd7835e074847c81b75e1c3cd755 SHA512 eaf7221c2dcb2cf0bcddcaf6064e52f3d1542edaf0238fa96ae62e27911b275a3bc7ee624fe655b0abd00055312f18582d49cafdccf339f7c38aa93ca5badea9 WHIRLPOOL b8703c52e42fdd34b54496a755327fca8a6fe03fbc500497e961a13bbb84dee58b29b7158ba44c5bc317c85103bcf4778381640fb8f1f8e719b1d886fa74fb9e
+DIST scipy-0.16.1.tar.gz 12221561 SHA256 ecd1efbb1c038accb0516151d1e6679809c6010288765eb5da6051550bf52260 SHA512 1761a943a0629179fd546fe3754b16101ca86b98eb0539b73614ea65bce24055ca898f295683eb3f3f63402ebbbb9248aa2a9f6a1d7d6cdf5e1e7486b15c1a8b WHIRLPOOL 3a3924a41cfb407b0fd91e7dfa2d29a8f6ee7694681fdfe58aefab0e1272e6c1e20c814344abc4ab7cbbbb7a8de7f5867819cee73ca624d8cbdcb5db456a8025
diff --git a/sci-libs/scipy/scipy-0.16.1.ebuild b/sci-libs/scipy/scipy-0.16.1.ebuild
new file mode 100644
index 000000000000..33610d66892d
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.16.1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+DOC_PV=${PV}
+
+inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${PV}.zip -> ${PN}-${DOC_PV}-html.zip
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${PV}.pdf -> ${PN}-${DOC_PV}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc sparse test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="
+ >=dev-python/numpy-1.6.2[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+DEPEND="${CDEPEND}
+ dev-lang/swig
+ >=dev-python/cython-0.22[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="${CDEPEND}
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+DOCS=( HACKING.rst.txt THANKS.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-${DOC_PV}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.0-blitz.patch
+ "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
+ "${PYTHON}" -c \
+ 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
+ || die
+ "${EPYTHON}" -c \
+ "import scipy, sys; r = scipy.test('fast',verbose=2); sys.exit(0 if r.wasSuccessful() else 1)" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ dodoc "${DISTDIR}"/${PN}*pdf
+ docinto html
+ dodoc -r "${WORKDIR}"/html/.
+ fi
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}