summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-10-03 14:40:53 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-10-03 14:41:35 -0600
commitff77abc98e9ddc1765499b896079c176f9e083b0 (patch)
tree3b51ec1326ea9605f26c5315111b544d1e59a2e9 /sci-libs
parentapp-admin/ansible: 2.9.13 stable amd64/x86 with cleanup (diff)
downloadgentoo-ff77abc98e9ddc1765499b896079c176f9e083b0.tar.gz
gentoo-ff77abc98e9ddc1765499b896079c176f9e083b0.tar.bz2
gentoo-ff77abc98e9ddc1765499b896079c176f9e083b0.zip
sci-libs/libecpint: initial commit
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libecpint/Manifest1
-rw-r--r--sci-libs/libecpint/libecpint-1.0.2.ebuild26
-rw-r--r--sci-libs/libecpint/metadata.xml17
3 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/libecpint/Manifest b/sci-libs/libecpint/Manifest
new file mode 100644
index 000000000000..fdaecf16277a
--- /dev/null
+++ b/sci-libs/libecpint/Manifest
@@ -0,0 +1 @@
+DIST libecpint-1.0.2.tar.gz 1161801 BLAKE2B 98b9264055bc9dab86ad54921f65380bca6cf96a2e6000bc061998367b3eeaffe122fa03ed83c75deb568ee7cce49ff85b97909bd57ae057a189025421dee82e SHA512 adf9394628a39d1e07e4f02bf4fad1c3d19cbfd9a9aa123d6151dddb78c7ef2c2cab07bc7060dba1d5114756c03964c2bd237c82203a1efb38b9facaaa24c74a
diff --git a/sci-libs/libecpint/libecpint-1.0.2.ebuild b/sci-libs/libecpint/libecpint-1.0.2.ebuild
new file mode 100644
index 000000000000..d59b2f4bddb5
--- /dev/null
+++ b/sci-libs/libecpint/libecpint-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Efficient evaluation of integrals over ab initio effective core potentials"
+HOMEPAGE="https://github.com/robashaw/libecpint"
+SRC_URI="https://github.com/robashaw/libecpint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-libs/pugixml
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ mycmakeargs=(
+ -DLIBECPINT_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/libecpint/metadata.xml b/sci-libs/libecpint/metadata.xml
new file mode 100644
index 000000000000..0802ee79be89
--- /dev/null
+++ b/sci-libs/libecpint/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Libecpint is a C++ library for the efficient evaluation of integrals over ab
+ initio effective core potentials, using a mixture of generated, recursive
+ code and Gauss-Chebyshev quadrature. It is designed to be standalone and
+ generic.
+</longdescription>
+ <upstream>
+ <remote-id type="github">robashaw/libecpint</remote-id>
+ </upstream>
+</pkgmetadata>