summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-15 21:44:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-15 21:54:11 +0200
commit743f7000d74f66ab38a9a5698b463d27d787b470 (patch)
tree73d3a5446b0704354309f980331089402a2ce6d1 /sci-mathematics/alt-ergo
parentdev-libs/libjcat: Bump to version 0.1.11 (diff)
downloadgentoo-743f7000d74f66ab38a9a5698b463d27d787b470.tar.gz
gentoo-743f7000d74f66ab38a9a5698b463d27d787b470.tar.bz2
gentoo-743f7000d74f66ab38a9a5698b463d27d787b470.zip
sci-mathematics/alt-ergo: bump to 2.4.1_p20220407
2022.04.07 snapshot; bumped to get new cmdliner dependency, added in https://github.com/OCamlPro/alt-ergo/commit/92e831bf26b6f9d1478cd263e46e1a088fea29a8 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/alt-ergo')
-rw-r--r--sci-mathematics/alt-ergo/Manifest1
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.1_p20220407.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/Manifest b/sci-mathematics/alt-ergo/Manifest
index 347d94ff7e6e..6ae0ff60295b 100644
--- a/sci-mathematics/alt-ergo/Manifest
+++ b/sci-mathematics/alt-ergo/Manifest
@@ -1,2 +1,3 @@
DIST alt-ergo-2.3.0.tar.gz 455577 BLAKE2B 1836782be452df5147fc3041517fd267f3ce7facd15ad460c3e1dfba2b6ea455fee79ad8264ccb12cf21622c21a54c186c9943e7bffb392daab15d046ff93863 SHA512 a2f209b62b8494bfefe84328cdc786185e0534c5e224e212b83045b078352a51d2ab02622f72c22c74c7de95c7a554cbdae2a9a8a0c41f3f26c841f8c72f6b21
DIST alt-ergo-2.4.1.tar.gz 2883046 BLAKE2B 6930080f7735f043e33d02b7fa0990c53992848796c0a5cf6ea4d7122eb6b9e5d6ac7ce420a4a19da35fa0ce5ff431bc228f2314a6f709f27a16bc7481bbacd5 SHA512 c3eee41d3c588ca89c2a1eebe9f10914ef647743b58fb562b682172cf6b6bdeb0920ebbba8a850820c0cb53bad0260f11b82fe71f00830ea9b33f5bb5d4fd048
+DIST alt-ergo-2.4.1_p20220407.tar.gz 2884310 BLAKE2B aaa31242de3ffe3f804de1e47fb740593812991e60eb583339ec0e1c56caa40b3c7f14108d068a1dbcbd7efc0d8fc96f1ba652a77c03170bddef90931a44c12c SHA512 4c353a359c92e121859f84455bb98bd80c0d33bb2001d6f2998a822e6b3dd65c9c56b0bdcaf93e52863afd8e999de6939d05859b5fc6de2ed9689c1d083bba0a
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.1_p20220407.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.1_p20220407.ebuild
new file mode 100644
index 000000000000..f76781a05972
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.1_p20220407.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=4e082218efe6e0e2315331580bbd08306c1f8a2d
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+
+ >=dev-ml/cmdliner-1.1.0:=
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ dev-ml/camlzip:=
+ dev-ml/num:=
+ dev-ml/seq:=
+ dev-ml/stdlib-shims:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/dune-configurator"
+
+src_prepare() {
+ default
+
+ # Remove the GTK2 GUI frontend because GTK2 in Gentoo is deprecated
+ rm -r src/bin/gui || die
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ dune-install alt-ergo-lib alt-ergo-parsers alt-ergo
+
+ use examples && dodoc -r examples
+}