summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-28 00:46:50 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-28 00:47:32 +0100
commit9c0afb6206ddcc225b50413cb8a46b8b0eded3cc (patch)
tree90a023eb538bf067a68ea15fcaf4a742b9af4289 /sci-mathematics/alt-ergo
parentsci-mathematics/psmt2-frontend: bump to 0.4.0 (diff)
downloadgentoo-9c0afb6206ddcc225b50413cb8a46b8b0eded3cc.tar.gz
gentoo-9c0afb6206ddcc225b50413cb8a46b8b0eded3cc.tar.bz2
gentoo-9c0afb6206ddcc225b50413cb8a46b8b0eded3cc.zip
sci-mathematics/alt-ergo: bump to 2.4.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/alt-ergo')
-rw-r--r--sci-mathematics/alt-ergo/Manifest1
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/Manifest b/sci-mathematics/alt-ergo/Manifest
index de070479a00e..347d94ff7e6e 100644
--- a/sci-mathematics/alt-ergo/Manifest
+++ b/sci-mathematics/alt-ergo/Manifest
@@ -1 +1,2 @@
DIST alt-ergo-2.3.0.tar.gz 455577 BLAKE2B 1836782be452df5147fc3041517fd267f3ce7facd15ad460c3e1dfba2b6ea455fee79ad8264ccb12cf21622c21a54c186c9943e7bffb392daab15d046ff93863 SHA512 a2f209b62b8494bfefe84328cdc786185e0534c5e224e212b83045b078352a51d2ab02622f72c22c74c7de95c7a554cbdae2a9a8a0c41f3f26c841f8c72f6b21
+DIST alt-ergo-2.4.1.tar.gz 2883046 BLAKE2B 6930080f7735f043e33d02b7fa0990c53992848796c0a5cf6ea4d7122eb6b9e5d6ac7ce420a4a19da35fa0ce5ff431bc228f2314a6f709f27a16bc7481bbacd5 SHA512 c3eee41d3c588ca89c2a1eebe9f10914ef647743b58fb562b682172cf6b6bdeb0920ebbba8a850820c0cb53bad0260f11b82fe71f00830ea9b33f5bb5d4fd048
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.1.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.1.ebuild
new file mode 100644
index 000000000000..9621bd865e68
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+ dev-ml/camlzip:=
+ dev-ml/num:=
+ dev-ml/seq:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Remove the GTK2 GUI frontend because GTK2 in Gentoo is deprecated
+ rm -r src/bin/gui || die
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ dune-install alt-ergo-lib alt-ergo-parsers alt-ergo
+
+ use examples && dodoc -r examples
+}