summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-08-12 10:51:48 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-08-12 13:31:37 -0400
commit95b409a673711361f0920fafec3905c871d43b54 (patch)
treecf0486d542e0bc6ca30150e15c94dc77c6da2361 /sci-mathematics/arb/arb-2.18.1.ebuild
parentsci-mathematics/flint: new version 2.6.3. (diff)
downloadgentoo-95b409a673711361f0920fafec3905c871d43b54.tar.gz
gentoo-95b409a673711361f0920fafec3905c871d43b54.tar.bz2
gentoo-95b409a673711361f0920fafec3905c871d43b54.zip
sci-mathematics/arb: new version 2.18.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/arb/arb-2.18.1.ebuild')
-rw-r--r--sci-mathematics/arb/arb-2.18.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/arb/arb-2.18.1.ebuild b/sci-mathematics/arb/arb-2.18.1.ebuild
new file mode 100644
index 000000000000..691185c1d346
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.18.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:="
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.18.0-multilib-strict.patch
+ "${FILESDIR}"/${PN}-2.18.0-build_type.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}