summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-07-10 10:24:35 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-26 13:06:05 +0200
commitc2d0457fbca7c4e64c9c4caa99708e7586725693 (patch)
tree0dece45431486c62cf89ce709710778378c3b83b /sci-mathematics/coq/coq-8.13.0-r1.ebuild
parentapp-emulation/lxc-templates: keyword ~riscv (diff)
downloadgentoo-c2d0457fbca7c4e64c9c4caa99708e7586725693.tar.gz
gentoo-c2d0457fbca7c4e64c9c4caa99708e7586725693.tar.bz2
gentoo-c2d0457fbca7c4e64c9c4caa99708e7586725693.zip
sci-mathematics/coq: use a dependency default flag
media-libs/netpbm is dropping zlib USE flag Closes: https://bugs.gentoo.org/801442 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21580 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-mathematics/coq/coq-8.13.0-r1.ebuild')
-rw-r--r--sci-mathematics/coq/coq-8.13.0-r1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/sci-mathematics/coq/coq-8.13.0-r1.ebuild b/sci-mathematics/coq/coq-8.13.0-r1.ebuild
new file mode 100644
index 000000000000..2ce871790746
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.13.0-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop findlib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/zarith
+ || (
+ dev-ml/num
+ <dev-lang/ocaml-4.09.0[ocamlopt?]
+ )
+ gtk? (
+ dev-ml/lablgtk:3=[sourceview,ocamlopt?]
+ dev-ml/lablgtk-sourceview:3=[ocamlopt?]
+ )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,postscript(+),zlib(+)]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install -j1 VERBOSE=1
+ dodoc README.md CREDITS
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}