summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-21 03:41:21 +0000
committerSam James <sam@gentoo.org>2021-02-21 03:41:21 +0000
commit31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4 (patch)
tree1fc7de1c8fbc690b972ad97f58f92fc4aaf1bf5a /sci-mathematics/euler
parentsys-process/parallel: Stabilize 20210122 arm, #771807 (diff)
downloadgentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.tar.gz
gentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.tar.bz2
gentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.zip
sci-mathematics/euler: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics/euler')
-rw-r--r--sci-mathematics/euler/euler-1.61.0-r1.ebuild (renamed from sci-mathematics/euler/euler-1.61.0.ebuild)26
-rw-r--r--sci-mathematics/euler/files/command-gcc4-gentoo.patch5
-rw-r--r--sci-mathematics/euler/files/configure-gentoo.patch10
-rw-r--r--sci-mathematics/euler/files/euler-fortify.patch15
-rw-r--r--sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch4
-rw-r--r--sci-mathematics/euler/files/euler-xdg.patch8
6 files changed, 31 insertions, 37 deletions
diff --git a/sci-mathematics/euler/euler-1.61.0.ebuild b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
index a938c5786928..b54a13030b48 100644
--- a/sci-mathematics/euler/euler-1.61.0.ebuild
+++ b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
@@ -1,12 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Mathematical programming environment"
HOMEPAGE="http://euler.sourceforge.net/"
@@ -14,13 +11,13 @@ SRC_URI="mirror://sourceforge/euler/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="x11-libs/gtk+:2
- virtual/pkgconfig"
-RDEPEND="x11-libs/gtk+:2
- x11-misc/xdg-utils"
+BDEPEND="virtual/pkgconfig"
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="
+ ${DEPEND}
+ x11-misc/xdg-utils
+"
PATCHES=(
"${FILESDIR}"/configure-gentoo.patch
@@ -31,6 +28,8 @@ PATCHES=(
)
src_prepare() {
+ default
+
# gentoo specific stuff
sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
sed -i \
@@ -38,5 +37,6 @@ src_prepare() {
Makefile.am docs/Makefile.am \
docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
|| die "sed for docs failed"
- autotools-utils_src_prepare
+
+ eautoreconf
}
diff --git a/sci-mathematics/euler/files/command-gcc4-gentoo.patch b/sci-mathematics/euler/files/command-gcc4-gentoo.patch
index c405d65bd76e..08c6c8dcd632 100644
--- a/sci-mathematics/euler/files/command-gcc4-gentoo.patch
+++ b/sci-mathematics/euler/files/command-gcc4-gentoo.patch
@@ -1,6 +1,5 @@
-diff -Naur euler-1.61.0/src/command.c euler-1.61.0-new/src/command.c
---- euler-1.61.0/src/command.c 2005-10-24 00:38:24.000000000 +0000
-+++ euler-1.61.0-new/src/command.c 2006-02-08 23:30:43.000000000 +0000
+--- a/src/command.c
++++ b/src/command.c
@@ -732,7 +732,7 @@
}
diff --git a/sci-mathematics/euler/files/configure-gentoo.patch b/sci-mathematics/euler/files/configure-gentoo.patch
index e1e7c6ef1e6b..b2c93ce03503 100644
--- a/sci-mathematics/euler/files/configure-gentoo.patch
+++ b/sci-mathematics/euler/files/configure-gentoo.patch
@@ -1,6 +1,5 @@
-diff -Naur euler-1.61.0/configure.in euler-1.61.0-new/configure.in
---- euler-1.61.0/configure.in 2005-10-30 16:40:27.000000000 +0000
-+++ euler-1.61.0-new/configure.in 2006-02-08 23:38:54.000000000 +0000
+--- a/configure.in
++++ b/configure.in
@@ -8,8 +8,6 @@
AM_CONFIG_HEADER(config.h)
@@ -21,9 +20,8 @@ diff -Naur euler-1.61.0/configure.in euler-1.61.0-new/configure.in
dnl Checks for header files.
-diff -Naur euler-1.61.0/src/Makefile.am euler-1.61.0-new/src/Makefile.am
---- euler-1.61.0/src/Makefile.am 2005-10-30 22:48:35.000000000 +0000
-+++ euler-1.61.0-new/src/Makefile.am 2006-02-08 23:41:32.000000000 +0000
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -7,10 +7,6 @@
INCLUDES = \
$(GTK_CFLAGS)
diff --git a/sci-mathematics/euler/files/euler-fortify.patch b/sci-mathematics/euler/files/euler-fortify.patch
index efb366e2cc04..dd68408879ed 100644
--- a/sci-mathematics/euler/files/euler-fortify.patch
+++ b/sci-mathematics/euler/files/euler-fortify.patch
@@ -1,6 +1,5 @@
-diff -Nur euler-1.61.0.orig/src/command.c euler-1.61.0/src/command.c
---- euler-1.61.0.orig/src/command.c 2010-11-19 17:50:54.000000000 +0000
-+++ euler-1.61.0/src/command.c 2010-11-19 18:23:11.000000000 +0000
+--- a/src/command.c
++++ b/src/command.c
@@ -606,7 +606,7 @@
void do_help (void)
{ char name[256];
@@ -10,9 +9,8 @@ diff -Nur euler-1.61.0.orig/src/command.c euler-1.61.0/src/command.c
char *p,*end,*pnote;
builtintyp *b;
scan_space();
-diff -Nur euler-1.61.0.orig/src/stack.h euler-1.61.0/src/stack.h
---- euler-1.61.0.orig/src/stack.h 2010-11-19 17:50:54.000000000 +0000
-+++ euler-1.61.0/src/stack.h 2010-11-19 18:19:23.000000000 +0000
+--- a/src/stack.h
++++ b/src/stack.h
@@ -63,7 +63,7 @@
#endif
} dims;
@@ -22,9 +20,8 @@ diff -Nur euler-1.61.0.orig/src/stack.h euler-1.61.0/src/stack.h
typedef struct { header hd; double val; } realtyp;
-diff -Nur euler-1.61.0.orig/src/udf.c euler-1.61.0/src/udf.c
---- euler-1.61.0.orig/src/udf.c 2010-11-19 17:50:54.000000000 +0000
-+++ euler-1.61.0/src/udf.c 2010-11-19 18:21:20.000000000 +0000
+--- a/src/udf.c
++++ b/src/udf.c
@@ -334,7 +334,7 @@
{ char name[16];
header *hd;
diff --git a/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch b/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch
index da377bd5f3ba..ddbb01a25986 100644
--- a/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch
+++ b/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch
@@ -1,7 +1,7 @@
# patch to fix missing CLK_TCK in glibc 2.4
---- src/main.c. 2006-04-04 15:05:34.000000000 +0200
-+++ src/main.c 2006-04-04 15:09:20.000000000 +0200
+--- a/src/main.c
++++ b/src/main.c
@@ -439,7 +439,7 @@
gettimer(TIMEOFDAY,&t);
return (t.tv_sec+t.tv_nsec/1000000000.0);
diff --git a/sci-mathematics/euler/files/euler-xdg.patch b/sci-mathematics/euler/files/euler-xdg.patch
index cb1bf54a2bbb..89edad38f97f 100644
--- a/sci-mathematics/euler/files/euler-xdg.patch
+++ b/sci-mathematics/euler/files/euler-xdg.patch
@@ -1,5 +1,5 @@
---- docs/doc.html.orig 2008-01-07 23:11:25.490634852 +0000
-+++ docs/doc.html 2008-01-07 23:13:57.652980222 +0000
+--- a/docs/doc.html
++++ b/docs/doc.html
@@ -184,7 +184,8 @@
<div align=center><img src="images/pref3.gif"></div>
@@ -10,8 +10,8 @@
You can also reset the preferences to the default values.</p>
<div align=center><img src="images/pref4.gif"></div>
---- src/rc.h.orig 2008-01-07 23:15:36.617118688 +0000
-+++ src/rc.h 2008-01-07 23:15:54.097371330 +0000
+--- a/src/rc.h
++++ b/src/rc.h
@@ -26,7 +26,7 @@
#define E_GSTACK_DEFAULT 4*1024l
#define E_GLINES_DEFAULT 40