summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/euler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/euler')
-rw-r--r--sci-mathematics/euler/Manifest1
-rw-r--r--sci-mathematics/euler/euler-1.61.0.ebuild43
-rw-r--r--sci-mathematics/euler/files/command-gcc4-gentoo.patch12
-rw-r--r--sci-mathematics/euler/files/configure-gentoo.patch37
-rw-r--r--sci-mathematics/euler/files/euler-fortify.patch36
-rw-r--r--sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch13
-rw-r--r--sci-mathematics/euler/files/euler-xdg.patch23
-rw-r--r--sci-mathematics/euler/metadata.xml8
8 files changed, 173 insertions, 0 deletions
diff --git a/sci-mathematics/euler/Manifest b/sci-mathematics/euler/Manifest
new file mode 100644
index 000000000000..b1411738a673
--- /dev/null
+++ b/sci-mathematics/euler/Manifest
@@ -0,0 +1 @@
+DIST euler-1.61.0.tgz 1202485 SHA256 1350a3ded26fa8bab2580a1dc3a689aabbb100b872df62819327282773e02d95 SHA512 f8b9b0c6aa5aea4bd42bd33fff986a52c624c268ede11b83c2c53293a5acbda45317ecc719c12f377b236460c7ff0dba1d110ee8e90b526fc70af03ed0327b27 WHIRLPOOL 46967a4d5cb82a3fcc42730c8ecdb5b529e176bd6b9dcf1055e7790f9d15cfc85eda60bae66543a6cca1fda73cf88f15bc200ac1cdc5c10347a1237fcaa06aae
diff --git a/sci-mathematics/euler/euler-1.61.0.ebuild b/sci-mathematics/euler/euler-1.61.0.ebuild
new file mode 100644
index 000000000000..1f8ab2c0f687
--- /dev/null
+++ b/sci-mathematics/euler/euler-1.61.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Mathematical programming environment"
+HOMEPAGE="http://euler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/euler/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="x11-libs/gtk+:2
+ virtual/pkgconfig"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-misc/xdg-utils"
+
+PATCHES=(
+ "${FILESDIR}"/configure-gentoo.patch
+ "${FILESDIR}"/command-gcc4-gentoo.patch
+ "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
+ "${FILESDIR}"/${PN}-xdg.patch
+ "${FILESDIR}"/${PN}-fortify.patch
+)
+
+src_prepare() {
+ # gentoo specific stuff
+ sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
+ sed -i \
+ -e "s:doc/euler:doc/${PF}:g" \
+ Makefile.am docs/Makefile.am \
+ docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
+ || die "sed for docs failed"
+ autotools-utils_src_prepare
+}
diff --git a/sci-mathematics/euler/files/command-gcc4-gentoo.patch b/sci-mathematics/euler/files/command-gcc4-gentoo.patch
new file mode 100644
index 000000000000..c405d65bd76e
--- /dev/null
+++ b/sci-mathematics/euler/files/command-gcc4-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur euler-1.61.0/src/command.c euler-1.61.0-new/src/command.c
+--- euler-1.61.0/src/command.c 2005-10-24 00:38:24.000000000 +0000
++++ euler-1.61.0-new/src/command.c 2006-02-08 23:30:43.000000000 +0000
+@@ -732,7 +732,7 @@
+ }
+
+
+-static int command_count;
++int command_count;
+
+ commandtyp command_list[] = {
+ {"quit",c_quit,do_quit},
diff --git a/sci-mathematics/euler/files/configure-gentoo.patch b/sci-mathematics/euler/files/configure-gentoo.patch
new file mode 100644
index 000000000000..e1e7c6ef1e6b
--- /dev/null
+++ b/sci-mathematics/euler/files/configure-gentoo.patch
@@ -0,0 +1,37 @@
+diff -Naur euler-1.61.0/configure.in euler-1.61.0-new/configure.in
+--- euler-1.61.0/configure.in 2005-10-30 16:40:27.000000000 +0000
++++ euler-1.61.0-new/configure.in 2006-02-08 23:38:54.000000000 +0000
+@@ -8,8 +8,6 @@
+ AM_CONFIG_HEADER(config.h)
+
+ AC_ISC_POSIX
+-CFLAGS=""
+-AC_SUBST(CFLAGS)
+ AC_PROG_CC
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+@@ -21,6 +19,10 @@
+
+
+ dnl Checks for libraries.
++dnl Check for libm for fmod()
++AC_SEARCH_LIBS([fmod], [m], [], [
++ AC_MSG_ERROR([unable to find the fmod() function])
++])
+
+
+ dnl Checks for header files.
+diff -Naur euler-1.61.0/src/Makefile.am euler-1.61.0-new/src/Makefile.am
+--- euler-1.61.0/src/Makefile.am 2005-10-30 22:48:35.000000000 +0000
++++ euler-1.61.0-new/src/Makefile.am 2006-02-08 23:41:32.000000000 +0000
+@@ -7,10 +7,6 @@
+ INCLUDES = \
+ $(GTK_CFLAGS)
+
+-AM_CFLAGS =\
+- -Wall\
+- -O3
+-
+ bin_PROGRAMS = euler
+
+ euler_SOURCES = \
diff --git a/sci-mathematics/euler/files/euler-fortify.patch b/sci-mathematics/euler/files/euler-fortify.patch
new file mode 100644
index 000000000000..efb366e2cc04
--- /dev/null
+++ b/sci-mathematics/euler/files/euler-fortify.patch
@@ -0,0 +1,36 @@
+diff -Nur euler-1.61.0.orig/src/command.c euler-1.61.0/src/command.c
+--- euler-1.61.0.orig/src/command.c 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/command.c 2010-11-19 18:23:11.000000000 +0000
+@@ -606,7 +606,7 @@
+ void do_help (void)
+ { char name[256];
+ header *hd;
+- int count,i,defaults;
++ size_t count,i,defaults;
+ char *p,*end,*pnote;
+ builtintyp *b;
+ scan_space();
+diff -Nur euler-1.61.0.orig/src/stack.h euler-1.61.0/src/stack.h
+--- euler-1.61.0.orig/src/stack.h 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/stack.h 2010-11-19 18:19:23.000000000 +0000
+@@ -63,7 +63,7 @@
+ #endif
+ } dims;
+
+-typedef struct { unsigned long s; } inttyp;
++typedef struct { size_t s; } inttyp;
+
+ typedef struct { header hd; double val; } realtyp;
+
+diff -Nur euler-1.61.0.orig/src/udf.c euler-1.61.0/src/udf.c
+--- euler-1.61.0.orig/src/udf.c 2010-11-19 17:50:54.000000000 +0000
++++ euler-1.61.0/src/udf.c 2010-11-19 18:21:20.000000000 +0000
+@@ -334,7 +334,7 @@
+ { char name[16];
+ header *hd;
+ char *p,*pnote;
+- int i,count,defaults;
++ size_t i,count,defaults;
+ builtintyp *b;
+ scan_space();
+ scan_name(name); hd=searchudf(name);
diff --git a/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch b/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch
new file mode 100644
index 000000000000..da377bd5f3ba
--- /dev/null
+++ b/sci-mathematics/euler/files/euler-glibc-2.4-gentoo.patch
@@ -0,0 +1,13 @@
+# patch to fix missing CLK_TCK in glibc 2.4
+
+--- src/main.c. 2006-04-04 15:05:34.000000000 +0200
++++ src/main.c 2006-04-04 15:09:20.000000000 +0200
+@@ -439,7 +439,7 @@
+ gettimer(TIMEOFDAY,&t);
+ return (t.tv_sec+t.tv_nsec/1000000000.0);
+ #else
+- return ((double)(times(NULL)))/CLK_TCK;
++ return ((double)(times(NULL)))/CLOCKS_PER_SEC;
+ #endif
+ }
+
diff --git a/sci-mathematics/euler/files/euler-xdg.patch b/sci-mathematics/euler/files/euler-xdg.patch
new file mode 100644
index 000000000000..cb1bf54a2bbb
--- /dev/null
+++ b/sci-mathematics/euler/files/euler-xdg.patch
@@ -0,0 +1,23 @@
+--- docs/doc.html.orig 2008-01-07 23:11:25.490634852 +0000
++++ docs/doc.html 2008-01-07 23:13:57.652980222 +0000
+@@ -184,7 +184,8 @@
+ <div align=center><img src="images/pref3.gif"></div>
+
+ <p align="justify">Finally, You can set a flag to let Euler save preferences at exit (the default).
+-You may choose another browser than the one suggested (netscape by default). And
++You may choose another browser than the one suggested (your default
++ desktop browser is selected with xdg-open by default). And
+ You can also reset the preferences to the default values.</p>
+ <div align=center><img src="images/pref4.gif"></div>
+
+--- src/rc.h.orig 2008-01-07 23:15:36.617118688 +0000
++++ src/rc.h 2008-01-07 23:15:54.097371330 +0000
+@@ -26,7 +26,7 @@
+ #define E_GSTACK_DEFAULT 4*1024l
+ #define E_GLINES_DEFAULT 40
+
+-#define E_BROWSER_DEFAULT "netscape"
++#define E_BROWSER_DEFAULT "xdg-open"
+
+ #define MAX_COLORS 16
+
diff --git a/sci-mathematics/euler/metadata.xml b/sci-mathematics/euler/metadata.xml
new file mode 100644
index 000000000000..8e1f11be3629
--- /dev/null
+++ b/sci-mathematics/euler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <upstream>
+ <remote-id type="sourceforge">euler</remote-id>
+ </upstream>
+</pkgmetadata>