summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-05-25 18:10:26 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-05-26 18:19:09 -0400
commit6398cd0e60eccff4466a9b5a38be3e25baa49e25 (patch)
tree64e81277edacf4723f7493dcb2f22e374150074d /sci-mathematics/flint
parentwww-client/vivaldi: Drop old 5.2.2623.46 (diff)
downloadgentoo-6398cd0e60eccff4466a9b5a38be3e25baa49e25.tar.gz
gentoo-6398cd0e60eccff4466a9b5a38be3e25baa49e25.tar.bz2
gentoo-6398cd0e60eccff4466a9b5a38be3e25baa49e25.zip
sci-mathematics/flint: new upstream v2.8.5.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/Manifest1
-rw-r--r--sci-mathematics/flint/flint-2.8.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index 02d1fe23a9fa..ecd1105730d7 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1,2 +1,3 @@
DIST flint-2.7.1.tar.gz 4945081 BLAKE2B 9dcc4b0062be08778cd8ada1794a73237ea091a7bff4a4673aa59eac9b414ed90e0291b9547bdf72aa30e48da11f98ff983267ea2e3dd1d75fcec00b24c86ca9 SHA512 abea97228e91089d82a9a44714e719064bef261c45f5f5b24700955bb841cc98a8182e04e6054fcbcaa3bd92f2f95a82bd5d168ec2171af6a58d4f71eb0a479a
DIST flint-2.8.4.tar.gz 5212964 BLAKE2B ddd3b9dca76ddac2070d3e12dfc4c5ea1a3b505c7bf28e41489798798d65ed2a5db12e01059816d42e5d1209166d17ee6035dcf0a94d991f78df59c6ad06b271 SHA512 1f66574a5f2f27e1f3cd0a334712c0e64f4a4b8dd57179a71f9adba4c4faff23ba8da3993f51c4f44f52a588d0d1678b1e1a272e8fe3367f2abc88e9d86ad804
+DIST flint-2.8.5.tar.gz 5212805 BLAKE2B 8922a2925b68d93fd35aa5b78eb0b8cbc6aa609498b8846ce4ff036c2fece3932a0eabb0f04a5c152147d8df3eccd6570832f55dafe4f7a35de135246454a83d SHA512 849fb61612f3becfde0d8afc019a9312a7ea07d3000a6bc558eb82babecd737e3af894d3084e4a57d52f7db0403d7298cbfa277b08e2b1f5497897637ed4825f
diff --git a/sci-mathematics/flint/flint-2.8.5.ebuild b/sci-mathematics/flint/flint-2.8.5.ebuild
new file mode 100644
index 000000000000..ade006fabbd2
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.8.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ninja doesn't like "-lcblas" so using make.
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+
+# flintlib.org tarballs have been broken in the past, Bill Hart suggests
+# we get them from Github (which he has control over).
+SRC_URI="https://github.com/wbhart/flint2/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/16"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-tex/latexmk
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )
+ virtual/cblas"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/flint2-${PV}"
+
+src_prepare() {
+ # https://github.com/wbhart/flint2/issues/1140
+ rm test/t-sdiv_qrnnd.c || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ -DCBLAS_INCLUDE_DIRS="${EPREFIX}/usr/include"
+ -DCBLAS_LIBRARIES="-lcblas"
+ )
+
+ cmake_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build html
+ cmake_build pdf
+ fi
+}