summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/genius/files/genius-make.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/genius/files/genius-make.patch')
-rw-r--r--sci-mathematics/genius/files/genius-make.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/genius/files/genius-make.patch b/sci-mathematics/genius/files/genius-make.patch
new file mode 100644
index 000000000000..b9754325aea4
--- /dev/null
+++ b/sci-mathematics/genius/files/genius-make.patch
@@ -0,0 +1,73 @@
+--- gtkextra/Makefile.in-orig 2010-08-22 16:18:31.099596456 -0500
++++ gtkextra/Makefile.in 2010-08-22 16:20:46.375575923 -0500
+@@ -106,16 +106,16 @@
+ first=`echo "$$dir1" | sed -e "$$sed_first"`; \
+ if test "$$first" != "."; then \
+ if test "$$first" = ".."; then \
+- dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
+- dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
++ dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
++ dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
+ else \
+- first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
+- if test "$$first2" = "$$first"; then \
+- dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
+- else \
+- dir2="../$$dir2"; \
+- fi; \
+- dir0="$$dir0"/"$$first"; \
++ first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
++ if test "$$first2" = "$$first"; then \
++ dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
++ else \
++ dir2="../$$dir2"; \
++ fi; \
++ dir0="$$dir0"/"$$first"; \
+ fi; \
+ fi; \
+ dir1=`echo "$$dir1" | sed -e "$$sed_rest"`; \
+@@ -391,7 +391,7 @@
+ case '$(am__configure_deps)' in \
+ *$$dep*) \
+ ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
+- && { if test -f $@; then exit 0; else break; fi; }; \
++ && { if test -f $@; then exit 0; else break; fi; }; \
+ exit 1;; \
+ esac; \
+ done; \
+@@ -670,12 +670,12 @@
+ echo " am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir)"; \
+ ($(am__cd) $$subdir && \
+ $(MAKE) $(AM_MAKEFLAGS) \
+- top_distdir="$$new_top_distdir" \
+- distdir="$$new_distdir" \
++ top_distdir="$$new_top_distdir" \
++ distdir="$$new_distdir" \
+ am__remove_distdir=: \
+ am__skip_length_check=: \
+ am__skip_mode_fix=: \
+- distdir) \
++ distdir) \
+ || exit 1; \
+ fi; \
+ done
+@@ -800,13 +800,13 @@
+
+
+ $(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ $(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
+ $(srcdir)/gtkextratypebuiltins.h: $(public_h_sources)
+ ( cd $(srcdir) && glib-mkenums \