summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2020-10-06 17:13:09 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-13 15:06:10 +0300
commitdd8e0c1ed0414518b52398f97769ac89b07f9717 (patch)
treea90c356b6ea929e85ab423aefd7980e360e255e8 /sci-mathematics/gimps/gimps-30.3.6.ebuild
parentsci-calculators/bc-gh: remove some old versions (diff)
downloadgentoo-dd8e0c1ed0414518b52398f97769ac89b07f9717.tar.gz
gentoo-dd8e0c1ed0414518b52398f97769ac89b07f9717.tar.bz2
gentoo-dd8e0c1ed0414518b52398f97769ac89b07f9717.zip
sci-mathematics/gimps: Version bump to gimps-30.3.6
Also switched source to https:// and used tmpfiles.eclass Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Closes: https://bugs.gentoo.org/746911 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://github.com/gentoo/gentoo/pull/17821 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics/gimps/gimps-30.3.6.ebuild')
-rw-r--r--sci-mathematics/gimps/gimps-30.3.6.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/gimps-30.3.6.ebuild b/sci-mathematics/gimps/gimps-30.3.6.ebuild
new file mode 100644
index 000000000000..c5644dfa342a
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.3.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}