summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2021-04-26 18:32:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-10 09:54:01 +0300
commit33a26872e32347c0e0a4a8becf136c818d8119c6 (patch)
tree6d3088b6d999a988674ca016bd47a1a9589506c9 /sci-mathematics/gimps/gimps-30.6.4.ebuild
parentapp-accessibility/speech-tools: removed obsolete 2.4-r1 (diff)
downloadgentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.tar.gz
gentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.tar.bz2
gentoo-33a26872e32347c0e0a4a8becf136c818d8119c6.zip
sci-mathematics/gimps: Version bump to 30.6 build 4
Closes: https://bugs.gentoo.org/785859 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/20550 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics/gimps/gimps-30.6.4.ebuild')
-rw-r--r--sci-mathematics/gimps/gimps-30.6.4.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/gimps-30.6.4.ebuild b/sci-mathematics/gimps/gimps-30.6.4.ebuild
new file mode 100644
index 000000000000..f1cf70e083a8
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.6.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz -> ${P}.linux64.tar.gz )
+ "
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+OPTINSTALLDIR="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt undoc.txt whatsnew.txt )
+
+src_install() {
+ dodir ${OPTINSTALLDIR}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${OPTINSTALLDIR}" || die
+ fperms a-w "${OPTINSTALLDIR}/mprime"
+ fowners root:0 "${OPTINSTALLDIR}"
+ fowners root:0 "${OPTINSTALLDIR}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}