summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-01-03 00:02:55 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-01-03 00:04:02 +0600
commitba8cc7951401f253480ce8746e2ed0472dacd029 (patch)
tree5778cef59aa7172a7e08b5182c4f2293d367d267 /sci-mathematics/ginac/ginac-1.6.6.ebuild
parentdev-perl/DateTime-Format-HTTP: amd64/x86 stable, (ALLARCHES policy) wrt bug #... (diff)
downloadgentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.tar.gz
gentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.tar.bz2
gentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.zip
sci-mathematics/ginac: bump to 1.6.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-mathematics/ginac/ginac-1.6.6.ebuild')
-rw-r--r--sci-mathematics/ginac/ginac-1.6.6.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/ginac-1.6.6.ebuild b/sci-mathematics/ginac/ginac-1.6.6.ebuild
new file mode 100644
index 000000000000..45bd7132571e
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.6.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-rpath )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${BUILD_DIR}/doc/reference"
+ emake html pdf
+ cd "${BUILD_DIR}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ cd "${BUILD_DIR}"/doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ newins reference/reference.pdf reference.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ fi
+}