summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-08-21 15:56:30 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-08-21 15:56:30 +0700
commit7eb9bacc1926ca74e60e2952b082e604462d4b3a (patch)
tree5e025919112db5558dbc3af24fe698e070015b4b /sci-mathematics/ginac
parentsci-mathematics/nestedsums: clean old (diff)
downloadgentoo-7eb9bacc1926ca74e60e2952b082e604462d4b3a.tar.gz
gentoo-7eb9bacc1926ca74e60e2952b082e604462d4b3a.tar.bz2
gentoo-7eb9bacc1926ca74e60e2952b082e604462d4b3a.zip
sci-mathematics/ginac: bump to 1.7.11
Closes: https://bugs.gentoo.org/725526 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/ginac')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.7.11.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index 235eb557b287..951c6a8b7208 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1,4 +1,5 @@
DIST ginac-1.6.6.tar.bz2 1028211 BLAKE2B 3f939e82cfa833ee5ba6714d4db38edf80de4e380b0bcacfe23992ca3c5eefbd719506cf77f57aebc1517968eff7d26c8d24d14167c596e5e7145458367074e8 SHA512 495ef255dd32e71ee91257a515c0566e56525e0c54c8955c19beaf9e2e55457f7d8171c7e5f6e4f29f555f5d262bbaf4edf4f033166c4904c016987a5029e958
+DIST ginac-1.7.11.tar.bz2 1077491 BLAKE2B 741e9c8adfec15c225c3656b935707f86292b98310b50533269b238d1a9746bf54d186074c879fdbdd23f915dde225d9ee34fdbd87977835e8f9e78af364d77d SHA512 35a029915c946fcc10ba7b78df6fe1ece9a9f2f6bc172816a923c35f5b495154ab356526b904ac2a16a1bd6b0a81c480c5abb39ef40238ca7b32d1acbf97276c
DIST ginac-1.7.2.tar.bz2 1056339 BLAKE2B 116be56df781d6e9675f914b9f75af86736183dbd26a1ff5e7f6f3cc79e4efc31449bc4fd5454b0f73cf189749a00f071d2b7cc519005e1f3b772b6b1521d508 SHA512 5c356beb8e0830b9f5805870f67298d4c19e512db8b8f46a37b490c19179a5c99e4497439e5adb575dd97e7deb5fe0b931a4b6db80e98a8e1e6f46977e33d8cf
DIST ginac-1.7.4.tar.bz2 1062724 BLAKE2B 742ec49629fecb14a2294ca9e8dc1df52cdad2d2e11cebbffa3c23a64592c597f872dd8294bc9324ea1f88e540f75015d09ea526ef9d67689943bb6c94325911 SHA512 740c221a0115bd233723f3032a77b1389122694b2893c52d4c7ed778c7332981c152f6ea81b35352882c14b42542f64963d5199af3f492af97f79a6e6c52156c
DIST ginac-1.7.8.tar.bz2 1075317 BLAKE2B 6ae917b442c090fa6c6b28f543eecfc2a8119a63d15494933f0cb1c979f018d6439551e52e92b6d50c8cf83ce2df66aca4bb6be947e5b18cbfab2539c42e0ad2 SHA512 4d5a0e52108aee2438362d66d6b5f3e3a108855fc2c0ab2bc521ddc9a2a87c9b1404ae5304ba7d1dbcf6e985bfe26c730e14f3f46d63d0bdffe242f4a948c6a0
diff --git a/sci-mathematics/ginac/ginac-1.7.11.ebuild b/sci-mathematics/ginac/ginac-1.7.11.ebuild
new file mode 100644
index 000000000000..bd90fbd5c1b4
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.7.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib flag-o-matic
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="https://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ append-cxxflags -std=c++14
+ econf --disable-rpath $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ pushd doc/reference >> /dev/null || die "pushd doc/reference failed"
+ emake html pdf
+ popd >> /dev/null
+ pushd doc/tutorial >> /dev/null || die "pushd doc/tutorial failed"
+ emake ginac.pdf ginac.html
+ popd >> /dev/null
+ fi
+}
+
+src_test() {
+ pushd ../${P}_build > /dev/null
+ emake check
+ popd > /dev/null
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "cannot rm lib${PN}.la"
+ fi
+ if use doc; then
+ pushd doc > /dev/null || die "pushd doc failed"
+ newdoc tutorial/ginac.pdf tutorial.pdf
+ newdoc reference/reference.pdf reference.pdf
+ docinto html/reference
+ dodoc -r reference/html_files/.
+ docinto html
+ newdoc tutorial/ginac.html tutorial.html
+ docinto examples
+ dodoc "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ popd > /dev/null
+ fi
+}