summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-01 19:56:38 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-01 20:03:52 +0200
commit530986e9eaf2fb8f4ef556737e89b0e1d8cab6e2 (patch)
treee3d8edb4393ffc3494d558ad369564b1f8cd7ae1 /sci-mathematics/gmm
parentkde-frameworks/baloo: x86 stable wrt bug #613220 (diff)
downloadgentoo-530986e9eaf2fb8f4ef556737e89b0e1d8cab6e2.tar.gz
gentoo-530986e9eaf2fb8f4ef556737e89b0e1d8cab6e2.tar.bz2
gentoo-530986e9eaf2fb8f4ef556737e89b0e1d8cab6e2.zip
sci-mathematics/gmm: Build in C++14 mode
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612294 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-mathematics/gmm')
-rw-r--r--sci-mathematics/gmm/gmm-5.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/gmm-5.1.ebuild b/sci-mathematics/gmm/gmm-5.1.ebuild
index f815c7743301..3165e306952b 100644
--- a/sci-mathematics/gmm/gmm-5.1.ebuild
+++ b/sci-mathematics/gmm/gmm-5.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit flag-o-matic
+
DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
SRC_URI="http://download.gna.org/getfem/stable/${P}.tar.gz"
HOMEPAGE="http://www-gmm.insa-toulouse.fr/getfem/"
@@ -11,3 +13,10 @@ LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}