summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-01-05 23:26:37 -0500
committerMichael Orlitzky <mjo@gentoo.org>2021-01-05 23:27:20 -0500
commitfeb82a12d3ccbb1b50cbb41481d32b9342f3dd38 (patch)
tree03a85d52b23f2e9d749bdd65c1320674d0de8306 /sci-mathematics/gp2c/gp2c-0.0.12.ebuild
parentsys-apps/pmount: Stabilize 0.9.99_alpha-r6 amd64, #751148 (diff)
downloadgentoo-feb82a12d3ccbb1b50cbb41481d32b9342f3dd38.tar.gz
gentoo-feb82a12d3ccbb1b50cbb41481d32b9342f3dd38.tar.bz2
gentoo-feb82a12d3ccbb1b50cbb41481d32b9342f3dd38.zip
sci-mathematics/gp2c: new upstream version 0.0.12.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/gp2c/gp2c-0.0.12.ebuild')
-rw-r--r--sci-mathematics/gp2c/gp2c-0.0.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-mathematics/gp2c/gp2c-0.0.12.ebuild b/sci-mathematics/gp2c/gp2c-0.0.12.ebuild
new file mode 100644
index 000000000000..a723e8a4894a
--- /dev/null
+++ b/sci-mathematics/gp2c/gp2c-0.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-"$(ver_rs 3 'pl')
+DESCRIPTION="A GP to C translator"
+HOMEPAGE="https://pari.math.u-bordeaux.fr/"
+SRC_URI="https://pari.math.u-bordeaux.fr/pub/pari/GP2C/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Perl is run on the build host to compile the descriptions in desc/,
+# see for example desc/Makefile.am.
+BDEPEND="dev-lang/perl"
+
+# This is the first version of pari to put pari.cfg where we expect it.
+DEPEND=">=sci-mathematics/pari-2.11.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --with-paricfg="${EPREFIX}/usr/share/pari/pari.cfg"
+}