summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorxfim <xavier.fim@gmail.com>2020-03-02 12:03:02 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-26 13:48:13 +0200
commitc73befec8e2b1bfae6cbf34fcb7b3aca2f840ee0 (patch)
tree246c791af8e12ff575f59d8ac9de6abe955795e8 /sci-mathematics/jags
parentmedia-gfx/fbgrab: version bump, add info about upstream repo (diff)
downloadgentoo-c73befec8e2b1bfae6cbf34fcb7b3aca2f840ee0.tar.gz
gentoo-c73befec8e2b1bfae6cbf34fcb7b3aca2f840ee0.tar.bz2
gentoo-c73befec8e2b1bfae6cbf34fcb7b3aca2f840ee0.zip
sci-mathematics/jags: Version bump for 4.3.0
Also, updated to EAPI 7. Closes: https://bugs.gentoo.org/711304 Closes: https://github.com/gentoo/gentoo/pull/14823 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Xavier Fernández i Marín <xavier.fim@gmail.com> Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/Manifest1
-rw-r--r--sci-mathematics/jags/jags-4.3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/jags/Manifest b/sci-mathematics/jags/Manifest
index c20bc1cbe762..b4a2fcb4f2d0 100644
--- a/sci-mathematics/jags/Manifest
+++ b/sci-mathematics/jags/Manifest
@@ -1 +1,2 @@
DIST JAGS-4.2.0.tar.gz 1875538 BLAKE2B 039cefdb546ec28b905f22a4ec3dfe6d85c64064701283fe38be59f53da971b523d8bb5b7c5efe3e9da81a255b064cb8b66cac2fd4e844883b7fcf89cdabdbb1 SHA512 316483cd1a879c70c9b8ad6f23665196b95b9745da3924a47e14f4b0fd7c1abf9237575561cb31044623594360b6e991de68e1d9746baedeb285c65b77baada8
+DIST JAGS-4.3.0.tar.gz 2057409 BLAKE2B 5820c66dd10cc90343d53b901b7dbc1acf85dca0f5f80280864190882f0af865edad877eb2cfd421ec2035d3ae843373da1facee8a10b6735e2fc0387d452949 SHA512 d0564c73ff45484afad532ed788353f9c0945cd9667030eed5be674492bf97524d05903b22d4995c1de8a331dba7b04425d009e114d98a38b4bfce5214518b36
diff --git a/sci-mathematics/jags/jags-4.3.0.ebuild b/sci-mathematics/jags/jags-4.3.0.ebuild
new file mode 100644
index 000000000000..0a07a6aa6740
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="https://mcmc-jags.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/4.x/Source/${MYP}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+}
+
+src_compile() {
+ emake all $(usex doc docs "")
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/manual/*.pdf
+ find "${ED}" -name '*.la' -delete || die
+}