summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-01-02 10:02:44 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-01-02 10:09:42 -0500
commit46dcd8b7ddede5fed198022282a445a0a7498dea (patch)
tree1b3396af3e97952eb8c655318d5c2bd1ea349cec /sci-mathematics/lrcalc/lrcalc-1.2.ebuild
parentsys-kernel/gentoo-sources: Clean-up of the 4.14.X series (diff)
downloadgentoo-46dcd8b7ddede5fed198022282a445a0a7498dea.tar.gz
gentoo-46dcd8b7ddede5fed198022282a445a0a7498dea.tar.bz2
gentoo-46dcd8b7ddede5fed198022282a445a0a7498dea.zip
sci-mathematics/lrcalc: new package for Littlewood-Richardson coeffs.
This package was imported from the sage-on-gentoo overlay with only a few changes: * Updated from EAPI=6 to EAPI=7. * Enabled the test suite, which passes for me. * Changed the HOMEPAGE/SRC_URI to use HTTPS, and follow a redirect. * Updated LICENSE from GPL-2 to GPL-2+ based on the upstream LICENSE file. The SageMath package can detect and use lrcalc from the system, so having this package installed will help Gentoo users of SageMath avoid pointless rebuilds of lrcalc. Closes: https://bugs.gentoo.org/704572 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/lrcalc/lrcalc-1.2.ebuild')
-rw-r--r--sci-mathematics/lrcalc/lrcalc-1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-mathematics/lrcalc/lrcalc-1.2.ebuild b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
new file mode 100644
index 000000000000..30805331116a
--- /dev/null
+++ b/sci-mathematics/lrcalc/lrcalc-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Littlewood-Richardson Calculator"
+HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2-includes.patch" )
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}