summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-06-01 18:24:34 +0700
committerAndrey Grozin <grozin@gentoo.org>2019-06-01 18:25:19 +0700
commit073c7f9a0c3ddc8610e809d1fb3082b32d8e3b9c (patch)
treeb8affc9fd548d66ae08e4513c2f0b0396354f29e /sci-mathematics/maxima/files/clozurecl-3.patch
parentapp-editors/beaver: Fix GCC-9.1 inlining (diff)
downloadgentoo-073c7f9a0c3ddc8610e809d1fb3082b32d8e3b9c.tar.gz
gentoo-073c7f9a0c3ddc8610e809d1fb3082b32d8e3b9c.tar.bz2
gentoo-073c7f9a0c3ddc8610e809d1fb3082b32d8e3b9c.zip
sci-mathematics/maxima: bump to 5.43.0
Closes: https://bugs.gentoo.org/show_bug.cgi?id=684670 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/maxima/files/clozurecl-3.patch')
-rw-r--r--sci-mathematics/maxima/files/clozurecl-3.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-mathematics/maxima/files/clozurecl-3.patch b/sci-mathematics/maxima/files/clozurecl-3.patch
new file mode 100644
index 000000000000..531c6caca9d1
--- /dev/null
+++ b/sci-mathematics/maxima/files/clozurecl-3.patch
@@ -0,0 +1,27 @@
+diff -r -U1 maxima-5.43.0.orig/configure.ac maxima-5.43.0/configure.ac
+--- maxima-5.43.0.orig/configure.ac 2019-05-31 00:52:28.000000000 +0200
++++ maxima-5.43.0/configure.ac 2019-06-01 12:08:22.549425058 +0200
+@@ -434,3 +434,3 @@
+ dnl n.b. openmcl_default_name is hardcoded in "with" message
+-openmcl_default_name=openmcl
++openmcl_default_name=ccl
+ AC_ARG_ENABLE(openmcl,
+diff -r -U1 maxima-5.43.0.orig/src/Makefile.am maxima-5.43.0/src/Makefile.am
+--- maxima-5.43.0.orig/src/Makefile.am 2019-05-31 00:52:28.000000000 +0200
++++ maxima-5.43.0/src/Makefile.am 2019-06-01 12:06:49.990422763 +0200
+@@ -392,3 +392,3 @@
+
+-EXECUTEOPENMCL = $(OPENMCL_NAME)
++EXECUTEOPENMCL = $(OPENMCL_NAME) --no-init
+ BUILT_FILES += $(OPENMCL_MAXIMA)
+diff -r -U1 maxima-5.43.0.orig/src/maxima.in maxima-5.43.0/src/maxima.in
+--- maxima-5.43.0.orig/src/maxima.in 2019-05-31 00:52:28.000000000 +0200
++++ maxima-5.43.0/src/maxima.in 2019-06-01 12:10:12.251427778 +0200
+@@ -221,5 +221,5 @@
+ if [ -x "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" ]; then
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -e '(cl-user::run)' -- "$@"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS --no-init -e '(cl-user::run)' -- "$@"
+ else
+- exec "@OPENMCL_NAME@" -I "$maxima_image_base.image" $MAXIMA_LISP_OPTIONS -e '(cl-user::run)' -- "$@"
++ exec "@OPENMCL_NAME@" -I "$maxima_image_base.image" $MAXIMA_LISP_OPTIONS --no-init -e '(cl-user::run)' -- "$@"
+ fi