summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-20 11:15:49 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-20 11:15:49 +0100
commit65054120a51d3a6b941f7e1e18e3f8c217647f4e (patch)
treed4ff050ba359f321d01f05c0dc382b90d40b0986 /sci-mathematics/msieve
parentsci-mathematics/maxima: Remove old (diff)
downloadgentoo-65054120a51d3a6b941f7e1e18e3f8c217647f4e.tar.gz
gentoo-65054120a51d3a6b941f7e1e18e3f8c217647f4e.tar.bz2
gentoo-65054120a51d3a6b941f7e1e18e3f8c217647f4e.zip
sci-mathematics/msieve: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/msieve')
-rw-r--r--sci-mathematics/msieve/Manifest1
-rw-r--r--sci-mathematics/msieve/files/fix-version2.patch14
-rw-r--r--sci-mathematics/msieve/msieve-1.51-r1.ebuild54
3 files changed, 0 insertions, 69 deletions
diff --git a/sci-mathematics/msieve/Manifest b/sci-mathematics/msieve/Manifest
index b17c16504f0f..3f312ad50ddd 100644
--- a/sci-mathematics/msieve/Manifest
+++ b/sci-mathematics/msieve/Manifest
@@ -1,2 +1 @@
DIST msieve-1.53.tar.gz 976135 BLAKE2B 587007c4273b9e0ceb6dd17fb9310070b760f68f8f1c56014a168242d0989069a5257de39cba30c939b3b7e02918635d12b3153d05cd2abb9e4a6445c7ef1886 SHA512 e50e8913d38ed4108f5f2ecdbb338968edd416c56c5b7a92d8598b81fc16014ce7c7df963101c65f5bc88d1c7b2d8dbaa572efbecf53d720430a327929c9ce12
-DIST msieve151.tar.gz 623885 BLAKE2B a222f49fb1c6a411e1e46a7ed153e1ba24bbb604b70034c2c0632f69096e6a08a6783b25a44ffcd2d6b6962a8713455c893eb9514fb54a13f28a5b6a9aea3867 SHA512 79c03b5d669de7f05e27fc59fa999f416f513e41cba822376b862c31439fc66cf8749034c1f8f967f745955a5271a484b23e950ffede23d3fa2737ae26dbb0d4
diff --git a/sci-mathematics/msieve/files/fix-version2.patch b/sci-mathematics/msieve/files/fix-version2.patch
deleted file mode 100644
index 6e956897bdf0..000000000000
--- a/sci-mathematics/msieve/files/fix-version2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- demo.c 2011-11-25 00:25:28.000000000 +0800
-+++ demo.c.new 2012-11-30 16:46:50.417333847 +0800
-@@ -81,9 +81,8 @@
- /*--------------------------------------------------------------------*/
- void print_usage(char *progname) {
-
-- printf("\nMsieve v. %d.%02d (SVN %s)\n", MSIEVE_MAJOR_VERSION,
-- MSIEVE_MINOR_VERSION,
-- MSIEVE_SVN_VERSION);
-+ printf("\nMsieve v. %d.%02d\n", MSIEVE_MAJOR_VERSION,
-+ MSIEVE_MINOR_VERSION);
-
- printf("\nusage: %s [options] [one_number]\n", progname);
- printf("\nnumbers starting with '0' are treated as octal,\n"
diff --git a/sci-mathematics/msieve/msieve-1.51-r1.ebuild b/sci-mathematics/msieve/msieve-1.51-r1.ebuild
deleted file mode 100644
index 25cedcc0c961..000000000000
--- a/sci-mathematics/msieve/msieve-1.51-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
-HOMEPAGE="https://sourceforge.net/projects/msieve/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="zlib +ecm mpi"
-
-DEPEND="
- ecm? ( sci-mathematics/gmp-ecm )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # TODO: Integrate ggnfs properly
- epatch \
- "${FILESDIR}"/${P}-reduce-printf.patch \
- "${FILESDIR}"/fix-version.patch \
- "${FILESDIR}"/fix-version2.patch
- sed -i -e 's/-march=k8//' Makefile || die
- sed -i -e 's/CC =/#CC =/' Makefile || die
- sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
- sed -i -e 's/LIBS += -lecm/LIBS += -lecm -lgomp/' Makefile || die
-}
-
-src_compile() {
- use ecm && export "ECM=1"
- use mpi && export "MPI=1"
- use zlib && export "ZLIB=1"
- emake \
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- OPT_FLAGS="${CFLAGS}" \
- all
-}
-
-src_install() {
- mkdir -p "${D}/usr/include/msieve"
- mkdir -p "${D}/usr/lib/"
- mkdir -p "${D}/usr/share/doc/${P}/"
- cp include/* "${D}/usr/include/msieve" || die "Failed to install"
- cp libmsieve.a "${D}/usr/lib/" || die "Failed to install"
- dobin msieve
- cp Readme* "${D}/usr/share/doc/${P}/" || die "Failed to install"
-}