summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2018-03-21 17:51:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-03-21 23:04:45 +0100
commit3613246e32e9e7d129f8b2bb981b816bdc6dd8c4 (patch)
tree649ae2b90c8c8cfaf8767ad6e00a60dcbea8c15a /sci-mathematics/octave/files
parentapp-editors/hteditor: pull format-string fixes, bug #521018 (diff)
downloadgentoo-3613246e32e9e7d129f8b2bb981b816bdc6dd8c4.tar.gz
gentoo-3613246e32e9e7d129f8b2bb981b816bdc6dd8c4.tar.bz2
gentoo-3613246e32e9e7d129f8b2bb981b816bdc6dd8c4.zip
sci-mathematics/octave: version bump to 4.2.2.
Closes: https://bugs.gentoo.org/650974 Closes: https://github.com/gentoo/gentoo/pull/7534
Diffstat (limited to 'sci-mathematics/octave/files')
-rw-r--r--sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch14
-rw-r--r--sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch16
-rw-r--r--sci-mathematics/octave/files/octave-4.2.2-ncurses-pkgconfig.patch37
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch b/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch
new file mode 100644
index 000000000000..80fc28013239
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.2.2-fix-qscintilla-detection.patch
@@ -0,0 +1,14 @@
+In Gentoo, QScintilla for Qt5 has the same library name
+as its Qt4 variant.
+
+--- a/m4/acinclude.m4
++++ b/m4/acinclude.m4
+@@ -1460,7 +1460,7 @@
+ ;;
+ 5)
+ QT_MODULES="Qt5Core Qt5Gui Qt5Network Qt5OpenGL Qt5PrintSupport"
+- octave_qscintilla_libnames="qscintilla2-qt5 qscintilla2_qt5 qt5scintilla2"
++ octave_qscintilla_libnames="qscintilla2_qt5 qscintilla2"
+ ;;
+ *)
+ AC_MSG_ERROR([Unrecognized Qt version $qt_version])
diff --git a/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch b/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch
new file mode 100644
index 000000000000..d80c23ec4224
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.2.2-imagemagick-configure.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1560,11 +1560,11 @@ if test $check_magick = yes; then
+ MAGICK_LIBS=
+
+ PKG_CHECK_EXISTS([$magick++], [
+- ## Make sure we only get -I, -L, and -l flags. Some Graphics/ImageMagick++
++ ## Make sure we only get -I, -D, -L, and -l flags. Some Graphics/ImageMagick++
+ ## packages add extra flags that are useful when building
+ ## Graphics/ImageMagick++ extentions. These extra flags break the
+ ## Octave build.
+- MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//')"
++ MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//' | $SED -e 's/\(-@<:@DI@:>@@<:@^ \t@:>@*\)\|\(-@<:@^ \t@:>@*\)/\1/g')"
+ MAGICK_LDFLAGS="$($PKG_CONFIG --libs-only-L $magick++ | $SED -e 's/^ *$//')"
+ MAGICK_LIBS="$($PKG_CONFIG --libs-only-l $magick++ | $SED -e 's/^ *$//')"
+
diff --git a/sci-mathematics/octave/files/octave-4.2.2-ncurses-pkgconfig.patch b/sci-mathematics/octave/files/octave-4.2.2-ncurses-pkgconfig.patch
new file mode 100644
index 000000000000..d20fef5c56e9
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.2.2-ncurses-pkgconfig.patch
@@ -0,0 +1,37 @@
+--- a/m4/acinclude.m4
++++ b/m4/acinclude.m4
+@@ -1327,32 +1327,8 @@
+ dnl Find a suitable termlib to use.
+ dnl
+ AC_DEFUN([OCTAVE_CHECK_LIB_TERMLIB], [
+- TERM_LIBS=
+- ac_octave_save_LIBS="$LIBS"
+- AC_SEARCH_LIBS([tputs],
+- [ncurses curses termcap terminfo termlib],
+- [], [])
+- LIBS="$ac_octave_save_LIBS"
+- case "$ac_cv_search_tputs" in
+- -l*)
+- TERM_LIBS="$ac_cv_search_tputs"
+- ;;
+- no)
+- warn_termlibs="I couldn't find -ltermcap, -lterminfo, -lncurses, -lcurses, or -ltermlib!"
+- AC_MSG_WARN([$warn_termlibs])
+- ;;
+- esac
+-
+-dnl Old code (9/9/2012). Delete when new code is definitely proven.
+-dnl
+-dnl for _termlib in ncurses curses termcap terminfo termlib; do
+-dnl AC_CHECK_LIB([${_termlib}], [tputs], [
+-dnl TERM_LIBS="-l${termlib}"
+-dnl octave_cv_lib_found_termlib=yes
+-dnl break])
+-dnl done
+-
+- AC_SUBST(TERM_LIBS)
++ PKG_CHECK_MODULES([TERM], [ncurses])
++ CPPFLAGS="${CPPFLAGS} ${TERM_CFLAGS}"
+ ])
+ dnl
+ dnl Check for the Qhull version.