summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2018-07-03 22:46:41 +1000
committerMark Wright <gienah@gentoo.org>2018-07-03 22:46:41 +1000
commit9bec43136e0fea48bb5e352b0ac9f14b78444690 (patch)
treebafb50ce079181220538a081fc42d8a526933728 /sci-mathematics/octave/files
parentapp-emulation/lxd: update metadata (diff)
downloadgentoo-9bec43136e0fea48bb5e352b0ac9f14b78444690.tar.gz
gentoo-9bec43136e0fea48bb5e352b0ac9f14b78444690.tar.bz2
gentoo-9bec43136e0fea48bb5e352b0ac9f14b78444690.zip
sci-mathematics/octave: Bump to 4.4.0, thanks Fabio Rossi
for providing a 4.4.0 ebuild and patches, thanks to Anton Kochkov for reporting 655308. Rename openssl USE flag to ssl, add support for USE libressl (not tested with libressl), thanks to Alessandro Barbieri for reporting 620864. Closes: https://bugs.gentoo.org/655308 Closes: https://bugs.gentoo.org/620864 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sci-mathematics/octave/files')
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch16
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch16
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch10
-rw-r--r--sci-mathematics/octave/files/octave-4.4.0-texi.patch11
4 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch b/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch
new file mode 100644
index 000000000000..ce81b801d99c
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.4.0-imagemagick-configure.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac 2018-04-30 19:03:56.000000000 +0200
++++ a/configure.ac.new 2018-05-22 12:23:30.371174341 +0200
+@@ -1946,11 +1946,11 @@
+ MAGICK_LIBS=
+
+ PKG_CHECK_EXISTS([$magick++], [
+- dnl Make sure we only get -I, -L, and -l flags.
++ dnl Make sure we only get -I, -D, -L, and -l flags.
+ dnl Some Graphics/ImageMagick++ dnl packages add extra flags that are
+ dnl useful when building Graphics/ImageMagick++ extentions. These extra
+ dnl flags break the Octave build.
+- MAGICK_CPPFLAGS="$($PKG_CONFIG --cflags-only-I $magick++ | $SED -e 's/^ *$//')"
++ MAGICK_CPPFLAGS=`$PKG_CONFIG --cflags $magick++ | sed -e 's/\(-@<:@DI@:>@@<:@^ \t@:>@*\)\|\(-@<:@^ \t@:>@*\)/\1/g'`
+ MAGICK_LDFLAGS="$($PKG_CONFIG --libs-only-L $magick++ | $SED -e 's/^ *$//')"
+ MAGICK_LIBS="$($PKG_CONFIG --libs-only-l $magick++ | $SED -e 's/^ *$//')"
+
diff --git a/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch b/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch
new file mode 100644
index 000000000000..2f651e0995ee
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.4.0-imagemagick.patch
@@ -0,0 +1,16 @@
+--- a/libinterp/corefcn/__magick_read__.cc 2018-05-22 12:25:37.688173855 +0200
++++ a/libinterp/corefcn/__magick_read__.cc.new 2018-05-22 12:32:51.475172200 +0200
+@@ -817,10 +817,11 @@
+ // depth is 8, there's a good chance that we will be limited. It
+ // is also the GraphicsMagick recommended setting and the default
+ // for ImageMagick.
+- if (QuantumDepth < 16)
++ using namespace Magick;
++ if (MAGICKCORE_QUANTUM_DEPTH < 16)
+ warning_with_id ("Octave:GraphicsMagick-Quantum-Depth",
+ "your version of %s limits images to %d bits per pixel\n",
+- MagickPackageName, QuantumDepth);
++ MagickPackageName, MAGICKCORE_QUANTUM_DEPTH);
+
+ initialized = true;
+ }
diff --git a/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch b/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch
new file mode 100644
index 000000000000..70ffbb471992
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.4.0-qt-5.11.patch
@@ -0,0 +1,10 @@
+--- octave-4.4.0-orig/libgui/src/settings-dialog.cc 2018-05-01 03:03:56.000000000 +1000
++++ octave-4.4.0/libgui/src/settings-dialog.cc 2018-07-03 19:35:41.865149269 +1000
+@@ -41,6 +41,7 @@
+ #include <QHash>
+ #include <QMessageBox>
+ #include <QTextCodec>
++#include <QButtonGroup>
+
+ #if defined (HAVE_QSCINTILLA)
+ # include "octave-qscintilla.h"
diff --git a/sci-mathematics/octave/files/octave-4.4.0-texi.patch b/sci-mathematics/octave/files/octave-4.4.0-texi.patch
new file mode 100644
index 000000000000..90ffa5361bf7
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.4.0-texi.patch
@@ -0,0 +1,11 @@
+--- a/doc/interpreter/module.mk 2018-04-30 19:03:56.000000000 +0200
++++ a/doc/interpreter/module.mk.new 2018-05-22 12:17:03.587175816 +0200
+@@ -368,6 +368,8 @@
+ $(AWK) -f $(srcdir)/%reldir%/mkcontrib.awk $(srcdir)/%reldir%/contributors.in > $@-t && \
+ mv $@-t $@
+
++%reldir%/preface.texi: %reldir%/contributors.texi
++
+ AUTHORS: %reldir%/preface.texi %reldir%/contributors.texi | %reldir%/$(octave_dirstamp)
+ $(AM_V_MAKEINFO)rm -f $@-t $@ && \
+ if [ "x$(srcdir)" != "x." ] && [ -f $(srcdir)/%reldir%/contributors.texi ] && [ ! -f %reldir%/contributors.texi ]; then \