summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-03-06 08:03:46 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-03-06 08:32:10 -0500
commit28d3931d4aa32d5da2b028127131c382051a5bab (patch)
tree029cd83fce20f7bcd21e91750096ccdbcecb69f6 /sci-mathematics/palp
parentprofiles: Drop masks for net-im/zoom (diff)
downloadgentoo-28d3931d4aa32d5da2b028127131c382051a5bab.tar.gz
gentoo-28d3931d4aa32d5da2b028127131c382051a5bab.tar.bz2
gentoo-28d3931d4aa32d5da2b028127131c382051a5bab.zip
sci-mathematics/palp: new package, add 2.21
Closes: https://bugs.gentoo.org/230441 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/palp')
-rw-r--r--sci-mathematics/palp/Manifest2
-rw-r--r--sci-mathematics/palp/metadata.xml26
-rw-r--r--sci-mathematics/palp/palp-2.21.ebuild45
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/palp/Manifest b/sci-mathematics/palp/Manifest
new file mode 100644
index 000000000000..2d53f34d0249
--- /dev/null
+++ b/sci-mathematics/palp/Manifest
@@ -0,0 +1,2 @@
+DIST PALP-v2.21.tar.bz2 226701 BLAKE2B f2b57b916b011089b11e3e90e42653b243cbc999c4650b867f3a8c22f7a1bc883778d9678310fe4ecce497690b92c6cef71378ee2177da130b4b14c207f2383b SHA512 ab38469fbd78e0e5db437d892e44aec181810c3d5fbe67739081396ea97db2e47facf658335790b8ea6a7e422a090dde95d79413a7980d29a65db1854aa52dc2
+DIST palp-manual-v1.pdf 517953 BLAKE2B 7243794d8bc62c58c8329a9db32958c1929feb27fae1779874a31c16c1e4fd641e4089d029402ad5188f385b4f20dd77fc82506990bcf252289b21ca1b084b58 SHA512 3cf9fe7038981a5c7aa9d73623e17dc7b944bd8b09b32964c196b2231c1621fbe6014e2b45b2b9db092adbdce27cbb72ea65ced5da0b1f010388fbbef1f534f7
diff --git a/sci-mathematics/palp/metadata.xml b/sci-mathematics/palp/metadata.xml
new file mode 100644
index 000000000000..b5439949c063
--- /dev/null
+++ b/sci-mathematics/palp/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">stringstuwien/PALP</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/palp/palp-2.21.ebuild b/sci-mathematics/palp/palp-2.21.ebuild
new file mode 100644
index 000000000000..92c0a3cb307c
--- /dev/null
+++ b/sci-mathematics/palp/palp-2.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# The arXiv version of the PDF manual
+MANUAL_PV=v1
+
+DESCRIPTION="A Package for Analyzing Lattice Polytopes (PALP)"
+HOMEPAGE="http://hep.itp.tuwien.ac.at/~kreuzer/CY/CYpalp.html
+ https://gitlab.com/stringstuwien/PALP"
+SRC_URI="https://gitlab.com/stringstuwien/PALP/-/archive/v${PV}/PALP-v${PV}.tar.bz2
+ https://arxiv.org/pdf/1205.4147${MANUAL_PV}.pdf -> ${PN}-manual-${MANUAL_PV}.pdf"
+S="${WORKDIR}/PALP-v${PV}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The "mori.x" program pipes input to "Singular".
+RDEPEND="sci-mathematics/singular"
+
+src_compile() {
+ # Build the additional foo-Nd.x (for N=4,5,6,11) programs needed by
+ # SageMath.
+ emake CC=$(tc-getCC) all-dims
+}
+
+src_install() {
+ einstalldocs
+ newdoc "${DISTDIR}/${PN}-manual-${MANUAL_PV}.pdf" "manual-${MANUAL_PV}.pdf"
+
+ local PROGS=( class cws mori nef poly )
+ local DIMS=( 4 5 6 11 )
+ for prog in "${PROGS[@]}"; do
+ for N in "${DIMS[@]}"; do
+ dobin "${prog}-${N}d.x"
+ done
+ # The default "make" builds only one variant of each program,
+ # foo.x, corresponding to foo-6d.x. Users will expect those
+ # names, so we create a symlink from them to foo-6d.x.
+ dosym "${prog}-6d.x" "/usr/bin/${prog}.x"
+ done
+}