summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-06 07:19:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-06 07:22:11 +0100
commitaed12ac2a6a2bae81f5dfc588b67cf650349cb37 (patch)
treec6e1d338df261da717638997e612b29242b0a8ca /sci-mathematics/picosat
parentprofiles: graduate loong profiles from exp status (diff)
downloadgentoo-aed12ac2a6a2bae81f5dfc588b67cf650349cb37.tar.gz
gentoo-aed12ac2a6a2bae81f5dfc588b67cf650349cb37.tar.bz2
gentoo-aed12ac2a6a2bae81f5dfc588b67cf650349cb37.zip
sci-mathematics/picosat: fix patch apply
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/picosat')
-rw-r--r--sci-mathematics/picosat/picosat-965.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-mathematics/picosat/picosat-965.ebuild b/sci-mathematics/picosat/picosat-965.ebuild
index cff148733b40..9803703a619b 100644
--- a/sci-mathematics/picosat/picosat-965.ebuild
+++ b/sci-mathematics/picosat/picosat-965.ebuild
@@ -13,12 +13,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
LICENSE="MIT"
+PATCHES=( "${FILESDIR}"/${P}-makefile.in.patch )
+
src_configure() {
CC="$(tc-getCC)" sh ./configure.sh --shared --trace || die
}
src_compile() {
- emake CFLAGS="${CFLAGS} ${LDFLAGS} -fPIC"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -fPIC"
}
src_install() {