summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:27 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:27 +0200
commitd2e8ea401edf0f3290c3bc3600df0bfa68418430 (patch)
tree70f97786ffb58b1d89d96ea5e4cbf798128b3dff /sci-mathematics/primecount/primecount-7.2-r1.ebuild
parentsci-mathematics/gretl: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-d2e8ea401edf0f3290c3bc3600df0bfa68418430.tar.gz
gentoo-d2e8ea401edf0f3290c3bc3600df0bfa68418430.tar.bz2
gentoo-d2e8ea401edf0f3290c3bc3600df0bfa68418430.zip
sci-mathematics/primecount: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/primecount/primecount-7.2-r1.ebuild')
-rw-r--r--sci-mathematics/primecount/primecount-7.2-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-mathematics/primecount/primecount-7.2-r1.ebuild b/sci-mathematics/primecount/primecount-7.2-r1.ebuild
index f84b7b7ea831..617ab1e08c27 100644
--- a/sci-mathematics/primecount/primecount-7.2-r1.ebuild
+++ b/sci-mathematics/primecount/primecount-7.2-r1.ebuild
@@ -8,6 +8,7 @@ inherit cmake toolchain-funcs
DESCRIPTION="Highly optimized CLI and library to count primes"
HOMEPAGE="https://github.com/kimwalisch/primecount"
SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="BSD-2"
SLOT="0/7" # subslot is first component of libprimecount.so version
KEYWORDS="amd64"
@@ -32,7 +33,11 @@ DOCS=(
)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {