summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-01-07 11:07:36 +1100
committerMark Wright <gienah@gentoo.org>2020-01-07 11:07:36 +1100
commit422dbf48dc19c6268e86dd4c1ca1217f7dd4df85 (patch)
tree581c862c88fffe2a49e9db677fd89352d0b4bf11 /sci-mathematics/prover9
parentdev-util/ccache: bump up to 3.7.7 (diff)
downloadgentoo-422dbf48dc19c6268e86dd4c1ca1217f7dd4df85.tar.gz
gentoo-422dbf48dc19c6268e86dd4c1ca1217f7dd4df85.tar.bz2
gentoo-422dbf48dc19c6268e86dd4c1ca1217f7dd4df85.zip
sci-mathematics/prover9: eapi=7, add src_test
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'sci-mathematics/prover9')
-rw-r--r--sci-mathematics/prover9/prover9-2009.11a.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/sci-mathematics/prover9/prover9-2009.11a.ebuild b/sci-mathematics/prover9/prover9-2009.11a.ebuild
index b9fe53f22b6a..1894b784a655 100644
--- a/sci-mathematics/prover9/prover9-2009.11a.ebuild
+++ b/sci-mathematics/prover9/prover9-2009.11a.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs versionator
+inherit eutils toolchain-funcs
MY_PN="LADR"
typeset -u MY_PV
-MY_PV=$(replace_all_version_separators '-')
+MY_PV=$(ver_rs 1 '-')
MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="Automated theorem prover for first-order and equational logic"
@@ -29,8 +29,8 @@ PATCHES=(
S="${WORKDIR}/${MY_P}/"
src_prepare() {
+ default
MAKEOPTS+=" -j1"
- epatch "${PATCHES[@]}"
sed \
-e "/^CC =/s:gcc:$(tc-getCC):g" \
-i */Makefile || die
@@ -40,6 +40,12 @@ src_compile() {
emake all
}
+src_test() {
+ emake test1
+ emake test2
+ emake test3
+}
+
src_install () {
dobin \
bin/attack \
@@ -95,7 +101,8 @@ src_install () {
manpages/rewriter.1 \
manpages/prover9-apps.1
- dohtml ladr/index.html.master ladr/html/*
+ docinto html
+ dodoc -r ladr/index.html.master ladr/html/*
insinto /usr/$(get_libdir)
dolib.so ladr/.libs/libladr.so.4.0.0