summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 12:03:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-15 20:48:37 +0200
commit1a16821be7eae5806efc3dffbc851b01706d4729 (patch)
tree7417ba4eb7be3498e68b8de0ad3f4a8e1d96703b /sci-mathematics/rkward/rkward-0.7.2.ebuild
parentdev-python/twine: stable 3.2.0 for hppa, bug #733850 (diff)
downloadgentoo-1a16821be7eae5806efc3dffbc851b01706d4729.tar.gz
gentoo-1a16821be7eae5806efc3dffbc851b01706d4729.tar.bz2
gentoo-1a16821be7eae5806efc3dffbc851b01706d4729.zip
sci-mathematics/rkward: 0.7.2 version bump
See also: https://mail.kde.org/pipermail/release-team/2020-October/012049.html Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-mathematics/rkward/rkward-0.7.2.ebuild')
-rw-r--r--sci-mathematics/rkward/rkward-0.7.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/rkward-0.7.2.ebuild b/sci-mathematics/rkward/rkward-0.7.2.ebuild
new file mode 100644
index 000000000000..a76b8cd6a799
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.7.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="https://rkward.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ LGPL-2"
+SLOT="5"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
+ dev-lang/R
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ kde-frameworks/kcompletion:5
+ kde-frameworks/kconfig:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kcrash:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kjobwidgets:5
+ kde-frameworks/knotifications:5
+ kde-frameworks/kparts:5
+ kde-frameworks/kservice:5
+ kde-frameworks/ktexteditor:5
+ kde-frameworks/kwidgetsaddons:5
+ kde-frameworks/kwindowsystem:5
+ kde-frameworks/kxmlgui:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ optfeature "kate plugins support" kde-apps/kate:${SLOT}
+ ecm_pkg_postinst
+}