summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2016-02-20 18:46:56 +1100
committerMark Wright <gienah@gentoo.org>2016-02-20 18:47:53 +1100
commit6fc8257f0c1be1c4ebd2f7db5486d43ab0749006 (patch)
treee94baabcf9177904dbffd18f9f5d9deb5d63ccdf /sci-mathematics/rstudio/files
parentapp-misc/ca-certificates: Stable for PPC64 (bug #561962). (diff)
downloadgentoo-6fc8257f0c1be1c4ebd2f7db5486d43ab0749006.tar.gz
gentoo-6fc8257f0c1be1c4ebd2f7db5486d43ab0749006.tar.bz2
gentoo-6fc8257f0c1be1c4ebd2f7db5486d43ab0749006.zip
sci-mathematics/rstudio: Bump to 0.99.879
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.99.879-clang-pandoc.patch77
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.99.879-paths.patch130
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.99.879-prefs.patch45
3 files changed, 252 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-0.99.879-clang-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-0.99.879-clang-pandoc.patch
new file mode 100644
index 000000000000..c3af2b7a6f56
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.99.879-clang-pandoc.patch
@@ -0,0 +1,77 @@
+--- rstudio-0.99.879-orig/src/cpp/session/CMakeLists.txt 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/src/cpp/session/CMakeLists.txt 2016-02-19 23:04:57.266186448 +1100
+@@ -25,30 +25,11 @@
+ if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-23")
+ message(FATAL_ERROR "Mathjax 2.3 not found (re-run install-dependencies script to install)")
+ endif()
+-if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
+- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
+-endif()
+ if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/rsconnect")
+ message(FATAL_ERROR "rsconnect package not found (re-run install-dependencies script to install)")
+ endif()
+
+
+-# verify libclang is installed
+-if(WIN32)
+- set(LIBCLANG_VERSION "3.4")
+-else()
+- set(LIBCLANG_VERSION "3.5")
+-endif()
+-set(LIBCLANG_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/${LIBCLANG_VERSION}")
+-if(NOT EXISTS "${LIBCLANG_DIR}")
+- message(FATAL_ERROR "libclang ${LIBCLANG_VERSION} not found (re-run install-dependencies script to install)")
+-endif()
+-set(LIBCLANG_HEADERS_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers")
+-if(NOT EXISTS "${LIBCLANG_HEADERS_DIR}")
+- message(FATAL_ERROR "libclang builtin-headers not found (re-run install-dependencies script to install)")
+-endif()
+-
+-
+ # include files
+ file(GLOB_RECURSE SESSION_HEADER_FILES "*.h*")
+
+@@ -399,18 +380,6 @@
+ install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-23"
+ DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources")
+
+- # install pandoc
+- if(RSTUDIO_PACKAGE_BUILD_SLES)
+- # when producing a SUSE Linux Enterpise build, we want to install the
+- # static Pandoc binaries (see dependencies/common/install-pandoc)
+- set(PANDOC_EXTENSION_DIR "/static")
+- endif()
+- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/1.15.2${PANDOC_EXTENSION_DIR}")
+- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
+- install(FILES ${PANDOC_FILES}
+- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
+-
+ # install rsconnect package
+ file(GLOB RSCONNECT_PACKAGE "${RSTUDIO_DEPENDENCIES_DIR}/common/rsconnect*.tar.gz")
+ install(FILES ${RSCONNECT_PACKAGE}
+@@ -428,24 +397,6 @@
+ install(DIRECTORY "resources/help_resources"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+
+- # install libclang
+- if(WIN32)
+- file(GLOB LIBCLANG_32_FILES "${LIBCLANG_DIR}/x86/libclang.*")
+- install(PROGRAMS ${LIBCLANG_32_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86)
+- file(GLOB LIBCLANG_64_FILES "${LIBCLANG_DIR}/x86_64/libclang.*")
+- install(PROGRAMS ${LIBCLANG_64_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86_64)
+- else()
+- file(GLOB_RECURSE LIBCLANG_FILES "${LIBCLANG_DIR}/libclang.*")
+- install(PROGRAMS ${LIBCLANG_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang)
+- endif()
+-
+- # install libclang builtin-headers
+- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers"
+- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources/libclang")
+-
+ # install 64 bit binaries if we are on win64
+ if(WIN32)
+ if(NOT ("$ENV{PROGRAMW6432}" STREQUAL ""))
diff --git a/sci-mathematics/rstudio/files/rstudio-0.99.879-paths.patch b/sci-mathematics/rstudio/files/rstudio-0.99.879-paths.patch
new file mode 100644
index 000000000000..a8b48f24968c
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.99.879-paths.patch
@@ -0,0 +1,130 @@
+--- rstudio-0.99.879-orig/CMakeGlobals.txt 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/CMakeGlobals.txt 2016-02-19 22:58:41.396818474 +1100
+@@ -120,7 +120,7 @@
+ else()
+ set(RSTUDIO_INSTALL_BIN bin)
+ endif()
+- set(RSTUDIO_INSTALL_SUPPORTING .)
++ set(RSTUDIO_INSTALL_SUPPORTING ${DISTRO_SHARE})
+ endif()
+
+ # if the install prefix is /usr/local then tweak as appropriate
+--- rstudio-0.99.879-orig/src/cpp/server/CMakeLists.txt 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/src/cpp/server/CMakeLists.txt 2016-02-19 22:58:41.397818478 +1100
+@@ -155,7 +155,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}
+- DESTINATION ${RSERVER_INITD_DEBIAN_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_DEBIAN_DIR})
+
+ # install configured redhat init.d script
+ set(RSERVER_INITD_REDHAT_DIR "extras/init.d/redhat")
+@@ -163,7 +163,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}
+- DESTINATION ${RSERVER_INITD_REDHAT_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_REDHAT_DIR})
+
+ # install configured suse init.d script
+ set(RSERVER_INITD_SUSE_DIR "extras/init.d/suse")
+@@ -171,13 +171,13 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_SUSE_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT}
+- DESTINATION ${RSERVER_INITD_SUSE_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_SUSE_DIR})
+
+ # install pam profile
+ set(RSERVER_PAM_DIR "extras/pam")
+ set(RSERVER_PAM_PROFILE "${RSERVER_PAM_DIR}/rstudio")
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_PAM_PROFILE}
+- DESTINATION ${RSERVER_PAM_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_PAM_DIR})
+
+ # install configured apparmor profile
+ set(RSERVER_APPARMOR_DIR "extras/apparmor")
+@@ -185,9 +185,9 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_APPARMOR_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_APPARMOR_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_APPARMOR_PROFILE}
+- DESTINATION ${RSERVER_APPARMOR_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_APPARMOR_DIR})
+ install(PROGRAMS ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_APPARMOR_DIR}/apparmor-profile-load
+- DESTINATION ${RSERVER_APPARMOR_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_APPARMOR_DIR})
+
+ # install configured upstart profile
+ set(RSERVER_UPSTART_DIR "extras/upstart")
+@@ -195,12 +195,12 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+ set(RSERVER_UPSTART_PROFILE_REDHAT "${RSERVER_UPSTART_DIR}/rstudio-server.redhat.conf")
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+
+ # install configured systemd profile
+ set(RSERVER_SYSTEMD_DIR "extras/systemd")
+--- rstudio-0.99.879-orig/src/cpp/server/ServerOptions.cpp 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/src/cpp/server/ServerOptions.cpp 2016-02-19 22:58:41.397818478 +1100
+@@ -382,8 +382,8 @@
+
+ // convert relative paths by completing from the system installation
+ // path (this allows us to be relocatable)
+- resolvePath(resourcePath, &wwwLocalPath_);
+- resolvePath(resourcePath, &wwwSymbolMapsPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
+ resolvePath(binaryPath, &authPamHelperPath_);
+ resolvePath(binaryPath, &rsessionPath_);
+ resolvePath(binaryPath, &rldpathPath_);
+--- rstudio-0.99.879-orig/src/cpp/session/SessionOptions.cpp 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/src/cpp/session/SessionOptions.cpp 2016-02-20 18:13:34.807771539 +1100
+@@ -49,7 +49,7 @@
+ namespace session {
+
+ namespace {
+-const char* const kDefaultPandocPath = "bin/pandoc";
++const char* const kDefaultPandocPath = "bin";
+ const char* const kDefaultPostbackPath = "bin/postback/rpostback";
+ const char* const kDefaultRsclangPath = "bin/rsclang";
+ } // anonymous namespace
+@@ -451,14 +451,14 @@
+ }
+
+ // convert relative paths by completing from the app resource path
+- resolvePath(resourcePath_, &rResourcesPath_);
+- resolvePath(resourcePath_, &agreementFilePath_);
+- resolvePath(resourcePath_, &wwwLocalPath_);
+- resolvePath(resourcePath_, &wwwSymbolMapsPath_);
+- resolvePath(resourcePath_, &coreRSourcePath_);
+- resolvePath(resourcePath_, &modulesRSourcePath_);
+- resolvePath(resourcePath_, &sessionLibraryPath_);
+- resolvePath(resourcePath_, &sessionPackageArchivesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &rResourcesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &agreementFilePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &coreRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &modulesRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionLibraryPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionPackageArchivesPath_);
+ resolvePostbackPath(resourcePath_, &rpostbackPath_);
+ #ifdef _WIN32
+ resolvePath(resourcePath_, &consoleIoPath_);
+@@ -467,7 +467,7 @@
+ resolvePath(resourcePath_, &msysSshPath_);
+ resolvePath(resourcePath_, &sumatraPath_);
+ #endif
+- resolvePath(resourcePath_, &hunspellDictionariesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &hunspellDictionariesPath_);
+ resolvePath(resourcePath_, &mathjaxPath_);
+ resolvePath(resourcePath_, &libclangHeadersPath_);
+ resolvePandocPath(resourcePath_, &pandocPath_);
diff --git a/sci-mathematics/rstudio/files/rstudio-0.99.879-prefs.patch b/sci-mathematics/rstudio/files/rstudio-0.99.879-prefs.patch
new file mode 100644
index 000000000000..483613cc5c09
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.99.879-prefs.patch
@@ -0,0 +1,45 @@
+--- rstudio-0.99.879-orig/src/gwt/build.xml 2016-02-12 09:24:39.000000000 +1100
++++ rstudio-0.99.879/src/gwt/build.xml 2016-02-20 00:25:39.458756693 +1100
+@@ -25,6 +25,7 @@
+ <property name="gwt.extra.args" value=""/>
+ <property name="gwt.main.module" value="org.rstudio.studio.RStudio"/>
+ <property name="ace.bin" value="src/org/rstudio/studio/client/workbench/views/source/editors/text/ace"/>
++ <property environment="env"/>
+
+ <path id="project.class.path">
+ <pathelement location="bin"/>
+@@ -101,8 +102,10 @@
+ <pathelement location="src"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <!-- add jvmarg -Xss16M or similar if you see a StackOverflowError -->
+ <jvmarg value="-Xmx1536M"/>
++ <jvmarg value="-Djava.util.prefs.userRoot=${env.T}"/>
+ <arg value="-war"/>
+ <arg value="www"/>
+ <arg value="-localWorkers"/>
+@@ -142,6 +145,7 @@
+ <pathelement location="src"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <jvmarg value="-Xmx2048M"/>
+ <arg value="-war"/>
+ <arg value="www"/>
+@@ -163,6 +167,7 @@
+ <pathelement location="src"/>
+ <path refid="project.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <jvmarg value="-Xmx2048M"/>
+ <arg value="-src"/>
+ <arg value = "src"/>
+@@ -194,6 +199,7 @@
+ <pathelement location="src"/>
+ <path refid="test.class.path"/>
+ </classpath>
++ <jvmarg value="-Duser.home=${env.T}"/>
+ <arg value="org.rstudio.studio.selenium.RStudioTestSuite"/>
+ </java>
+ </sequential>