summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-20 18:53:44 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-20 18:53:44 +0100
commit81c6a4956dd1bfed76c9845066f5ab0db75475ce (patch)
treec54dcfd913541afc3e22990866e79230a34145b3 /sci-mathematics/rstudio/files
parentmedia-libs/mesa: Version bump to 19.3.1 (diff)
downloadgentoo-81c6a4956dd1bfed76c9845066f5ab0db75475ce.tar.gz
gentoo-81c6a4956dd1bfed76c9845066f5ab0db75475ce.tar.bz2
gentoo-81c6a4956dd1bfed76c9845066f5ab0db75475ce.zip
sci-mathematics/rstudio: Fix building with boost 1.72
Closes: https://bugs.gentoo.org/703124 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch8
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch31
2 files changed, 35 insertions, 4 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
index 7eafd4386abd..56601de5341c 100644
--- a/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
+++ b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
@@ -1,7 +1,7 @@
---- rstudio-1.0.44-orig/src/cpp/server/CMakeLists.txt 2016-10-19 08:32:41.000000000 +1100
-+++ rstudio-1.0.44/src/cpp/server/CMakeLists.txt 2016-12-02 11:11:45.259050839 +1100
-@@ -203,17 +203,12 @@
- DESTINATION ${RSERVER_UPSTART_DIR})
+--- a/src/cpp/server/CMakeLists.txt
++++ b/src/cpp/server/CMakeLists.txt
+@@ -232,17 +232,12 @@
+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
# install configured systemd profile
- set(RSERVER_SYSTEMD_DIR "extras/systemd")
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch
new file mode 100644
index 000000000000..b2c4d2392f6a
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch
@@ -0,0 +1,31 @@
+From a11d0454e5fe9c50005a03b9d9de84355df5c7fd Mon Sep 17 00:00:00 2001
+From: Kevin Ushey <kevinushey@gmail.com>
+Date: Fri, 15 Nov 2019 14:54:02 -0800
+Subject: [PATCH] avoid use of deprecated APIs
+
+---
+ src/cpp/core/FilePath.cpp | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/src/cpp/shared_core/FilePath.cpp b/src/cpp/shared_core/FilePath.cpp
+index 088366a9d6..495289e7fc 100644
+--- a/src/cpp/core/FilePath.cpp
++++ b/src/cpp/core/FilePath.cpp
+@@ -22,8 +22,6 @@
+ #include <windows.h>
+ #endif
+
+-#define BOOST_FILESYSTEM_NO_DEPRECATED
+-
+ #define BOOST_NO_CXX11_SCOPED_ENUMS
+ #include <boost/filesystem.hpp>
+ #undef BOOST_NO_CXX11_SCOPED_ENUMS
+@@ -1032,7 +1030,7 @@
+ {
+ // NOTE: The path gets round-tripped through toString/fromString, would
+ // be nice to have a direct constructor
+- if (!iterationFunction(itr.level(),
++ if (!iterationFunction(itr.depth(),
+ FilePath(BOOST_FS_PATH2STR(itr->path()))))
+ {
+ // end the iteration if requested