summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-20 11:15:56 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-20 11:15:56 +0100
commitd6d966179522dadafb1ce5910eee146fc9a3f719 (patch)
tree676a2f4aae00214629a4952d5a59680a2783e9b6 /sci-mathematics/rstudio/files
parentsci-mathematics/twelf: Remove old (diff)
downloadgentoo-d6d966179522dadafb1ce5910eee146fc9a3f719.tar.gz
gentoo-d6d966179522dadafb1ce5910eee146fc9a3f719.tar.bz2
gentoo-d6d966179522dadafb1ce5910eee146fc9a3f719.zip
sci-mathematics/rstudio: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p1.patch46
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p2.patch17
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-core.patch160
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.1335-qtsingleapplication.patch60
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch32
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch118
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch83
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5042-R-4.0.0.patch106
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.3.959-R-4.0.0.patch106
9 files changed, 0 insertions, 728 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p1.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p1.patch
deleted file mode 100644
index 1ec458bb8698..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p1.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- rstudio-1.2.1335-orig/src/cpp/ext/websocketpp/transport/asio/connection.hpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/ext/websocketpp/transport/asio/connection.hpp 2019-08-20 22:38:53.808923305 +1000
-@@ -296,7 +296,11 @@
- */
- timer_ptr set_timer(long duration, timer_handler callback) {
- timer_ptr new_timer = lib::make_shared<boost::asio::deadline_timer>(
-+#if defined(BOOST_VERSION) && BOOST_VERSION >= 107000
-+ *m_io_service,
-+#else
- lib::ref(*m_io_service),
-+#endif
- boost::posix_time::milliseconds(duration)
- );
-
---- rstudio-1.2.1335-orig/src/cpp/ext/websocketpp/transport/asio/endpoint.hpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/ext/websocketpp/transport/asio/endpoint.hpp 2019-08-20 22:38:53.822923358 +1000
-@@ -184,7 +184,12 @@
- m_io_service = ptr;
- m_external_io_service = true;
- m_acceptor = lib::make_shared<boost::asio::ip::tcp::acceptor>(
-- lib::ref(*m_io_service));
-+#if defined(BOOST_VERSION) && BOOST_VERSION >= 107000
-+ *m_io_service
-+#else
-+ lib::ref(*m_io_service)
-+#endif
-+ );
-
- m_state = READY;
- ec = lib::error_code();
---- rstudio-1.2.1335-orig/src/cpp/ext/websocketpp/transport/asio/security/none.hpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/ext/websocketpp/transport/asio/security/none.hpp 2019-08-20 22:38:53.823923362 +1000
-@@ -167,7 +167,12 @@
- }
-
- m_socket = lib::make_shared<boost::asio::ip::tcp::socket>(
-- lib::ref(*service));
-+#if defined(BOOST_VERSION) && BOOST_VERSION >= 107000
-+ *service
-+#else
-+ lib::ref(*service)
-+#endif
-+ );
-
- m_state = READY;
-
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p2.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p2.patch
deleted file mode 100644
index eed2c5c955cb..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.70.0_p2.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- rstudio-1.2.1335-orig/src/cpp/core/include/core/http/TcpIpAsyncConnector.hpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/core/include/core/http/TcpIpAsyncConnector.hpp 2019-04-09 22:08:45.331273559 +1000
-@@ -77,7 +77,13 @@
- {
- // start a timer that will cancel any outstanding asynchronous operations
- // when it elapses if the connection operation has not succeeded
-- pConnectionTimer_.reset(new boost::asio::deadline_timer(resolver_.get_io_service(), timeout));
-+ pConnectionTimer_.reset(new boost::asio::deadline_timer(
-+#if BOOST_VERSION >= 107000
-+ resolver_.get_executor(),
-+#else
-+ resolver_.get_io_service(),
-+#endif
-+ timeout));
- pConnectionTimer_->async_wait(boost::bind(&TcpIpAsyncConnector::onConnectionTimeout,
- TcpIpAsyncConnector::shared_from_this(),
- boost::asio::placeholders::error));
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-core.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-core.patch
deleted file mode 100644
index 2c4374bb8045..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.1335-core.patch
+++ /dev/null
@@ -1,160 +0,0 @@
---- rstudio-1.2.1335-orig/src/cpp/session/SessionClientInit.cpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/session/SessionClientInit.cpp 2019-04-09 18:15:37.746363789 +1000
-@@ -87,13 +87,13 @@
- boost::shared_ptr<http::Cookie>* pCookie)
- {
- // extract the base URL
-- json::JsonRpcRequest request;
-+ core::json::JsonRpcRequest request;
- Error error = parseJsonRpcRequest(ptrConnection->request().body(), &request);
- if (error)
- return error;
- std::string baseURL;
-
-- error = json::readParams(request.params, &baseURL);
-+ error = core::json::readParams(request.params, &baseURL);
- if (error)
- return error;
-
-@@ -161,7 +161,7 @@
- }
-
- // prepare session info
-- json::Object sessionInfo ;
-+ core::json::Object sessionInfo ;
- sessionInfo["clientId"] = clientId;
- sessionInfo["mode"] = options.programMode();
-
-@@ -175,8 +175,8 @@
- }
-
- // temp dir
-- FilePath tempDir = rstudio::r::session::utils::tempDir();
-- Error error = tempDir.ensureDirectory();
-+ core::FilePath tempDir = rstudio::r::session::utils::tempDir();
-+ core::Error error = tempDir.ensureDirectory();
- if (error)
- LOG_ERROR(error);
- sessionInfo["temp_dir"] = tempDir.absolutePath();
-@@ -194,12 +194,12 @@
- sessionInfo["prompt"] = rstudio::r::options::getOption<std::string>("prompt");
-
- // client state
-- json::Object clientStateObject;
-+ core::json::Object clientStateObject;
- rstudio::r::session::clientState().currentState(&clientStateObject);
- sessionInfo["client_state"] = clientStateObject;
-
- // source documents
-- json::Array jsonDocs;
-+ core::json::Array jsonDocs;
- error = modules::source::clientInitDocuments(&jsonDocs);
- if (error)
- LOG_ERROR(error);
-@@ -224,7 +224,7 @@
- if (resumed)
- {
- // console actions
-- json::Object actionsObject;
-+ core::json::Object actionsObject;
- consoleActions.asJson(&actionsObject);
- sessionInfo["console_actions"] = actionsObject;
- }
-@@ -290,12 +290,12 @@
- }
- else
- {
-- sessionInfo["active_project_file"] = json::Value();
-- sessionInfo["project_ui_prefs"] = json::Value();
-- sessionInfo["project_open_docs"] = json::Value();
-+ sessionInfo["active_project_file"] = core::json::Value();
-+ sessionInfo["project_ui_prefs"] = core::json::Value();
-+ sessionInfo["project_open_docs"] = core::json::Value();
- sessionInfo["project_supports_sharing"] = false;
- sessionInfo["project_owned_by_user"] = false;
-- sessionInfo["project_user_data_directory"] = json::Value();
-+ sessionInfo["project_user_data_directory"] = core::json::Value();
- }
-
- sessionInfo["system_encoding"] = std::string(::locale2charset(NULL));
-@@ -332,20 +332,20 @@
- sessionInfo["build_tools_bookdown_website"] =
- module_context::isBookdownWebsite();
-
-- FilePath buildTargetDir = projects::projectContext().buildTargetPath();
-+ core::FilePath buildTargetDir = projects::projectContext().buildTargetPath();
- if (!buildTargetDir.empty())
- {
- sessionInfo["build_target_dir"] = module_context::createAliasedPath(
- buildTargetDir);
-- sessionInfo["has_pkg_src"] = (type == r_util::kBuildTypePackage) &&
-+ sessionInfo["has_pkg_src"] = (type == core::r_util::kBuildTypePackage) &&
- buildTargetDir.childPath("src").exists();
- sessionInfo["has_pkg_vig"] =
-- (type == r_util::kBuildTypePackage) &&
-+ (type == core::r_util::kBuildTypePackage) &&
- buildTargetDir.childPath("vignettes").exists();
- }
- else
- {
-- sessionInfo["build_target_dir"] = json::Value();
-+ sessionInfo["build_target_dir"] = core::json::Value();
- sessionInfo["has_pkg_src"] = false;
- sessionInfo["has_pkg_vig"] = false;
- }
-@@ -353,9 +353,9 @@
- }
- else
- {
-- sessionInfo["build_tools_type"] = r_util::kBuildTypeNone;
-+ sessionInfo["build_tools_type"] = core::r_util::kBuildTypeNone;
- sessionInfo["build_tools_bookdown_website"] = false;
-- sessionInfo["build_target_dir"] = json::Value();
-+ sessionInfo["build_target_dir"] = core::json::Value();
- sessionInfo["has_pkg_src"] = false;
- sessionInfo["has_pkg_vig"] = false;
- }
-@@ -364,7 +364,7 @@
- sessionInfo["presentation_commands"] = options.allowPresentationCommands();
-
- sessionInfo["tutorial_api_available"] = false;
-- sessionInfo["tutorial_api_client_origin"] = json::Value();
-+ sessionInfo["tutorial_api_client_origin"] = core::json::Value();
-
- sessionInfo["build_state"] = modules::build::buildStateAsJson();
- sessionInfo["devtools_installed"] = module_context::isMinimumDevtoolsInstalled();
-@@ -375,7 +375,7 @@
-
- // console history -- we do this at the end because
- // restoreBuildRestartContext may have reset it
-- json::Array historyArray;
-+ core::json::Array historyArray;
- rstudio::r::session::consoleHistory().asJson(&historyArray);
- sessionInfo["console_history"] = historyArray;
- sessionInfo["console_history_capacity"] =
-@@ -447,14 +447,14 @@
-
- sessionInfo["multi_session"] = options.multiSession();
-
-- json::Object rVersionsJson;
-+ core::json::Object rVersionsJson;
- rVersionsJson["r_version"] = module_context::rVersion();
- rVersionsJson["r_version_label"] = module_context::rVersionLabel();
- rVersionsJson["r_home_dir"] = module_context::rHomeDir();
- sessionInfo["r_versions_info"] = rVersionsJson;
-
- sessionInfo["show_user_home_page"] = options.showUserHomePage();
-- sessionInfo["user_home_page_url"] = json::Value();
-+ sessionInfo["user_home_page_url"] = core::json::Value();
-
- sessionInfo["r_addins"] = modules::r_addins::addinRegistryAsJson();
- sessionInfo["package_provided_extensions"] = modules::ppe::indexer().getPayload();
-@@ -491,7 +491,7 @@
-
- // create response (we always set kEventsPending to false so that the client
- // won't poll for events until it is ready)
-- json::JsonRpcResponse jsonRpcResponse;
-+ core::json::JsonRpcResponse jsonRpcResponse;
- jsonRpcResponse.setField(kEventsPending, "false");
- jsonRpcResponse.setResult(sessionInfo);
-
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-qtsingleapplication.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-qtsingleapplication.patch
deleted file mode 100644
index a59fa02f1d2c..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.1335-qtsingleapplication.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- rstudio-1.2.1335-orig/src/cpp/desktop/CMakeLists.txt 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/desktop/CMakeLists.txt 2019-04-09 18:04:57.783616412 +1000
-@@ -140,6 +140,13 @@
- get_filename_component(QT_LIBRARY_PATH "${QT_BIN_DIR}/../lib" ABSOLUTE CACHE)
- get_filename_component(QT_INSTALL_PATH "${QT_BIN_DIR}/.." ABSOLUTE CACHE)
-
-+find_path(QTSINGLEAPPLIB_INCLUDE_DIR NAMES QtSingleApplication
-+ PATH_SUFFIXES QtSolutions
-+ PATHS
-+ /usr/include/qt5)
-+find_library(QTSINGLEAPPLIB Qt5Solutions_SingleApplication-2.6
-+ libQt5Solutions_SingleApplication-2.6)
-+
- # disable clang warnings for qt sources
- if(APPLE)
- add_definitions(-Wno-unused-private-field
-@@ -158,7 +165,6 @@
-
- set(MOC_DESKTOP_HEADER_FILES ${DESKTOP_HEADER_FILES})
- list(REMOVE_ITEM MOC_DESKTOP_HEADER_FILES
-- ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/qtsingleapplication/qtlockedfile.h
- ${CMAKE_CURRENT_SOURCE_DIR}/DesktopDetectRHome.hpp
- ${CMAKE_CURRENT_SOURCE_DIR}/DesktopOptions.hpp
- ${CMAKE_CURRENT_SOURCE_DIR}/DesktopRVersion.hpp
-@@ -224,8 +230,6 @@
- DesktopSlotBinders.cpp
- DesktopSubMenu.cpp
- DesktopSynctex.cpp
-- 3rdparty/qtsingleapplication/qtsingleapplication.cpp
-- 3rdparty/qtsingleapplication/qtlocalpeer.cpp
- )
-
- if(WIN32)
-@@ -280,6 +284,7 @@
- ${CORE_SOURCE_DIR}/include
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_BINARY_DIR}
-+ ${QTSINGLEAPPLIB_INCLUDE_DIR}
- ${TESTS_INCLUDE_DIR}
- )
-
-@@ -384,6 +389,7 @@
- # set link dependencies
- target_link_libraries(rstudio
- ${RSTUDIO_QTMODULES}
-+ ${QTSINGLEAPPLIB}
- ${QT_LIBRARIES}
- ${Boost_LIBRARIES}
- rstudio-core
---- rstudio-1.2.1335-orig/src/cpp/desktop/DesktopPosixApplication.hpp 2019-03-28 16:08:20.000000000 +1100
-+++ rstudio-1.2.1335/src/cpp/desktop/DesktopPosixApplication.hpp 2019-04-09 18:01:39.333920927 +1000
-@@ -16,7 +16,7 @@
- #ifndef DESKTOP_POSIX_APPLICATION_HPP
- #define DESKTOP_POSIX_APPLICATION_HPP
-
--#include "3rdparty/qtsingleapplication/QtSingleApplication"
-+#include <QtSingleApplication>
-
- #include "DesktopApplicationLaunch.hpp"
-
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch
deleted file mode 100644
index b4f611063e17..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.5033-pandoc.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- rstudio-1.2.5033-orig/src/cpp/session/CMakeLists.txt 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/session/CMakeLists.txt 2020-01-07 12:29:20.174304185 +1100
-@@ -25,9 +25,6 @@
- if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26")
- message(FATAL_ERROR "Mathjax 2.6 not found (re-run install-dependencies script to install)")
- endif()
--if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
-- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
--endif()
-
- # we often install embedded versions of these packages but don't do so currently
-
-@@ -490,19 +487,6 @@
- install(DIRECTORY "resources/connections"
- DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
-
-- # install pandoc
-- if(WIN32)
-- set(PANDOC_VERSION "2.7.2" CACHE INTERNAL "Pandoc version")
-- else()
-- set(PANDOC_VERSION "2.3.1" CACHE INTERNAL "Pandoc version")
-- endif()
--
-- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/${PANDOC_VERSION}")
-- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
-- install(FILES ${PANDOC_FILES}
-- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
-- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
--
- # install rmarkdown package
- # file(GLOB RMARKDOWN_PACKAGE "${RSTUDIO_DEPENDENCIES_DIR}/common/rmarkdown*.tar.gz")
- # install(FILES ${RMARKDOWN_PACKAGE}
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
deleted file mode 100644
index aa6a9b23fdec..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
+++ /dev/null
@@ -1,118 +0,0 @@
---- rstudio-1.2.5033-orig/CMakeGlobals.txt 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/CMakeGlobals.txt 2020-01-07 12:20:19.115307754 +1100
-@@ -175,7 +175,7 @@
- else()
- set(RSTUDIO_INSTALL_BIN bin)
- endif()
-- set(RSTUDIO_INSTALL_SUPPORTING .)
-+ set(RSTUDIO_INSTALL_SUPPORTING ${DISTRO_SHARE})
- endif()
-
- # if the install prefix is /usr/local then tweak as appropriate
---- rstudio-1.2.5033-orig/src/cpp/server/CMakeLists.txt 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/server/CMakeLists.txt 2020-01-07 12:17:32.736309024 +1100
-@@ -194,7 +194,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}
-- DESTINATION ${RSERVER_INITD_DEBIAN_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_DEBIAN_DIR})
-
- # install configured redhat init.d script
- set(RSERVER_INITD_REDHAT_DIR "extras/init.d/redhat")
-@@ -202,7 +202,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}
-- DESTINATION ${RSERVER_INITD_REDHAT_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_REDHAT_DIR})
-
- # install configured suse init.d script
- set(RSERVER_INITD_SUSE_DIR "extras/init.d/suse")
-@@ -210,13 +210,13 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_SUSE_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT}
-- DESTINATION ${RSERVER_INITD_SUSE_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_SUSE_DIR})
-
- # install pam profile
- set(RSERVER_PAM_DIR "extras/pam")
- set(RSERVER_PAM_PROFILE "${RSERVER_PAM_DIR}/rstudio")
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_PAM_PROFILE}
-- DESTINATION ${RSERVER_PAM_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_PAM_DIR})
-
- # install configured upstart profile
- set(RSERVER_UPSTART_DIR "extras/upstart")
-@@ -224,12 +224,12 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE}
-- DESTINATION ${RSERVER_UPSTART_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
- set(RSERVER_UPSTART_PROFILE_REDHAT "${RSERVER_UPSTART_DIR}/rstudio-server.redhat.conf")
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}
-- DESTINATION ${RSERVER_UPSTART_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
-
- # install configured systemd profile
- set(RSERVER_SYSTEMD_DIR "extras/systemd")
---- rstudio-1.2.5033-orig/src/cpp/server/ServerOptions.cpp 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/server/ServerOptions.cpp 2020-01-07 12:17:32.773309023 +1100
-@@ -389,8 +389,8 @@
-
- // convert relative paths by completing from the system installation
- // path (this allows us to be relocatable)
-- resolvePath(resourcePath, &wwwLocalPath_);
-- resolvePath(resourcePath, &wwwSymbolMapsPath_);
-+ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwLocalPath_);
-+ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
- resolvePath(binaryPath, &authPamHelperPath_);
- resolvePath(binaryPath, &rsessionPath_);
- resolvePath(binaryPath, &rldpathPath_);
---- rstudio-1.2.5033-orig/src/cpp/session/SessionOptions.cpp 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/session/SessionOptions.cpp 2020-01-07 12:17:32.774309023 +1100
-@@ -53,7 +53,7 @@
- namespace session {
-
- namespace {
--const char* const kDefaultPandocPath = "bin/pandoc";
-+const char* const kDefaultPandocPath = "bin";
- const char* const kDefaultPostbackPath = "bin/postback/rpostback";
- const char* const kDefaultRsclangPath = "bin/rsclang";
-
-@@ -571,14 +571,14 @@
- }
-
- // convert relative paths by completing from the app resource path
-- resolvePath(resourcePath_, &rResourcesPath_);
-- resolvePath(resourcePath_, &agreementFilePath_);
-- resolvePath(resourcePath_, &wwwLocalPath_);
-- resolvePath(resourcePath_, &wwwSymbolMapsPath_);
-- resolvePath(resourcePath_, &coreRSourcePath_);
-- resolvePath(resourcePath_, &modulesRSourcePath_);
-- resolvePath(resourcePath_, &sessionLibraryPath_);
-- resolvePath(resourcePath_, &sessionPackageArchivesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &rResourcesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &agreementFilePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwLocalPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &coreRSourcePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &modulesRSourcePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionLibraryPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionPackageArchivesPath_);
- resolvePostbackPath(resourcePath_, &rpostbackPath_);
- #ifdef _WIN32
- resolvePath(resourcePath_, &consoleIoPath_);
-@@ -611,7 +611,7 @@
- }
- winptyPath_ = pty.complete(completion).absolutePath();
- #endif // _WIN32
-- resolvePath(resourcePath_, &hunspellDictionariesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &hunspellDictionariesPath_);
- resolvePath(resourcePath_, &mathjaxPath_);
- resolvePath(resourcePath_, &libclangHeadersPath_);
- resolvePandocPath(resourcePath_, &pandocPath_);
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch
deleted file mode 100644
index 034eba37a8b9..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.5033-prefs.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- rstudio-1.2.5033-orig/src/gwt/build.xml 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/gwt/build.xml 2020-01-10 18:35:29.913030923 +1100
-@@ -28,17 +28,35 @@
- classname="com.google.javascript.jscomp.ant.CompileTask"
- classpath="${tools.dir}/compiler/compiler.jar"/>
-
-+ <!-- Configure path to aopalliance -->
-+ <property name="aopalliance.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/aopalliance-1/lib"/>
-+
-+ <!-- Configure path to javax-inject -->
-+ <property name="javax.inject" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/javax-inject/lib"/>
-+
-+ <!-- Configure path to validation-api -->
-+ <property name="validation.api" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/validation-api-1.0/lib"/>
-+ <property name="validation.api.sources" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/validation-api-1.0/sources"/>
-+
- <!-- Configure path to GWT SDK -->
-- <property name="gwt.sdk" value="${lib.dir}/gwt/2.8.1"/>
-+ <property name="gwt.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/gwt-2.8/lib"/>
-+
-+ <!-- Configure path to Google Gin -->
-+ <property name="gin.sdk" value="@GENTOO_PORTAGE_EPREFIX@/usr/share/gin-2.1/lib"/>
-
- <property name="gwt.extra.args" value=""/>
- <property name="gwt.main.module" value="org.rstudio.studio.RStudio"/>
- <property name="ace.bin" value="${src.dir}/org/rstudio/studio/client/workbench/views/source/editors/text/ace"/>
-+ <property environment="env"/>
-
- <path id="project.class.path">
- <pathelement location="${build.dir}"/>
-+ <fileset dir="${aopalliance.sdk}" includes="*.jar"/>
-+ <fileset dir="${javax.inject}" includes="*.jar"/>
-+ <fileset dir="${validation.api}" includes="*.jar"/>
-+ <fileset dir="${validation.api.sources}" includes="*.zip"/>
- <fileset dir="${gwt.sdk}" includes="*.jar"/>
-- <fileset dir="${lib.dir}/gin/2.1.2" includes="*.jar"/>
-+ <fileset dir="${gin.sdk}" includes="*.jar"/>
- </path>
-
- <path id="test.class.path">
-@@ -112,8 +130,10 @@
- <pathelement location="${src.dir}"/>
- <path refid="project.class.path"/>
- </classpath>
-+ <jvmarg value="-Duser.home=${env.T}"/>
- <!-- add jvmarg -Xss16M or similar if you see a StackOverflowError -->
- <jvmarg value="-Xmx1536M"/>
-+ <jvmarg value="-Djava.util.prefs.userRoot=${env.T}"/>
- <arg value="-war"/>
- <arg value="${www.dir}"/>
- <arg value="-localWorkers"/>
-@@ -154,6 +174,7 @@
- <pathelement location="${src.dir}"/>
- <path refid="project.class.path"/>
- </classpath>
-+ <jvmarg value="-Duser.home=${env.T}"/>
- <jvmarg value="-Xmx2048M"/>
- <arg value="-style"/>
- <arg value="PRETTY"/>
-@@ -176,6 +197,7 @@
- <pathelement location="src"/>
- <path refid="project.class.path"/>
- </classpath>
-+ <jvmarg value="-Duser.home=${env.T}"/>
- <jvmarg value="-Xmx2048M"/>
- <arg value="-style"/>
- <arg value="PRETTY"/>
-@@ -202,6 +224,7 @@
- <pathelement location="src"/>
- <path refid="project.class.path"/>
- </classpath>
-+ <jvmarg value="-Duser.home=${env.T}"/>
- <jvmarg value="-Xmx2048M"/>
- <arg value="-src"/>
- <arg value = "src"/>
-@@ -237,6 +260,7 @@
- <pathelement location="${test.dir}"/>
- <pathelement location="${src.dir}"/>
- </classpath>
-+ <jvmarg value="-Duser.home=${env.T}"/>
- <classpath refid="project.class.path"/>
- <classpath refid="unittest.class.path"/>
- <arg value="org.rstudio.studio.client.RStudioUnitTestSuite"/>
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5042-R-4.0.0.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5042-R-4.0.0.patch
deleted file mode 100644
index 87ec83a7d4af..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.5042-R-4.0.0.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-From 71b1a935762efd24a79de193662450de5a89f67e Mon Sep 17 00:00:00 2001
-From: Jonathan McPherson <jonathan@rstudio.com>
-Date: Tue, 14 Jan 2020 12:53:20 -0800
-Subject: [PATCH] use R_NoSave over R_Slave for R 4.0+
-
----
- src/cpp/r/CMakeLists.txt | 12 ++++++++++++
- src/cpp/r/config.h.in | 8 +++++++-
- src/cpp/r/session/REmbeddedPosix.cpp | 20 ++++++++++++++------
- 3 files changed, 33 insertions(+), 7 deletions(-)
-
-diff --git a/src/cpp/r/CMakeLists.txt b/src/cpp/r/CMakeLists.txt
-index 6984ae309c..29784b8b67 100644
---- a/src/cpp/r/CMakeLists.txt
-+++ b/src/cpp/r/CMakeLists.txt
-@@ -15,6 +15,18 @@
-
- project (R)
-
-+# find the version of R in play
-+find_package(LibR REQUIRED)
-+execute_process(
-+ COMMAND "${LIBR_EXECUTABLE}" "--vanilla" "--slave" "-e" "cat(as.character(getRversion()))"
-+ OUTPUT_VARIABLE LIBR_VERSION)
-+
-+# parse and save the R version to a variable
-+string(REPLACE "." ";" R_VERSION_LIST "${LIBR_VERSION}")
-+list(GET R_VERSION_LIST 0 R_VERSION_MAJOR)
-+list(GET R_VERSION_LIST 1 R_VERSION_MINOR)
-+list(GET R_VERSION_LIST 2 R_VERSION_PATCH)
-+
- # include files
- file(GLOB_RECURSE R_HEADER_FILES "*.h*")
-
-diff --git a/src/cpp/r/config.h.in b/src/cpp/r/config.h.in
-index 6ba67c8e09..00bc8b6191 100644
---- a/src/cpp/r/config.h.in
-+++ b/src/cpp/r/config.h.in
-@@ -1,7 +1,7 @@
- /*
- * config.h.in
- *
-- * Copyright (C) 2009-12 by RStudio, Inc.
-+ * Copyright (C) 2009-20 by RStudio, Inc.
- *
- * Unless you have received this program directly from RStudio pursuant
- * to the terms of a commercial license agreement with RStudio, then
-@@ -16,4 +16,10 @@
-
- #cmakedefine PANGO_CAIRO_FOUND
-
-+// Important: These variables represent the version of R found during
-+// compile/link time, NOT the version of R present at runtime.
-+#define R_VERSION_MAJOR ${R_VERSION_MAJOR}
-+#define R_VERSION_MINOR ${R_VERSION_MINOR}
-+#define R_VERSION_PATCH ${R_VERSION_PATCH}
-+
-
-diff --git a/src/cpp/r/session/REmbeddedPosix.cpp b/src/cpp/r/session/REmbeddedPosix.cpp
-index ac71b94522..73e2e2ce7f 100644
---- a/src/cpp/r/session/REmbeddedPosix.cpp
-+++ b/src/cpp/r/session/REmbeddedPosix.cpp
-@@ -1,7 +1,7 @@
- /*
- * REmbeddedPosix.cpp
- *
-- * Copyright (C) 2009-12 by RStudio, Inc.
-+ * Copyright (C) 2009-20 by RStudio, Inc.
- *
- * Unless you have received this program directly from RStudio pursuant
- * to the terms of a commercial license agreement with RStudio, then
-@@ -38,6 +38,8 @@ extern "C" void (*ptr_R_ProcessEvents)(void);
- extern "C" typedef void (*ptr_QuartzCocoa_SetupEventLoop)(int, unsigned long);
- #endif
-
-+#include "config.h"
-+
- extern int R_running_as_main_program; // from unix/system.c
-
- using namespace rstudio::core;
-@@ -103,14 +105,20 @@ void runEmbeddedR(const core::FilePath& /*rHome*/, // ignored on posix
- //
- structRstart rp;
- Rstart Rp = &rp;
-- R_DefParams(Rp) ;
-- Rp->R_Slave = FALSE ;
-+ R_DefParams(Rp);
-+#if R_VERSION_MAJOR > 3
-+ // R 4.0 and above use --no-echo to suppress output
-+ Rp->R_NoEcho = FALSE;
-+#else
-+ // R 3.x and below use --slave
-+ Rp->R_Slave = FALSE;
-+#endif
- Rp->R_Quiet = quiet ? TRUE : FALSE;
-- Rp->R_Interactive = TRUE ;
-- Rp->SaveAction = defaultSaveAction ;
-+ Rp->R_Interactive = TRUE;
-+ Rp->SaveAction = defaultSaveAction;
- Rp->RestoreAction = SA_NORESTORE; // handled within initialize()
- Rp->LoadInitFile = loadInitFile ? TRUE : FALSE;
-- R_SetParams(Rp) ;
-+ R_SetParams(Rp);
-
- // redirect console
- R_Interactive = TRUE; // should have also been set by call to Rf_initialize_R
diff --git a/sci-mathematics/rstudio/files/rstudio-1.3.959-R-4.0.0.patch b/sci-mathematics/rstudio/files/rstudio-1.3.959-R-4.0.0.patch
deleted file mode 100644
index dc35d0ce0083..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.3.959-R-4.0.0.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-From 71b1a935762efd24a79de193662450de5a89f67e Mon Sep 17 00:00:00 2001
-From: Jonathan McPherson <jonathan@rstudio.com>
-Date: Tue, 14 Jan 2020 12:53:20 -0800
-Subject: [PATCH] use R_NoSave over R_Slave for R 4.0+
-
----
- src/cpp/r/CMakeLists.txt | 12 ++++++++++++
- src/cpp/r/config.h.in | 8 +++++++-
- src/cpp/r/session/REmbeddedPosix.cpp | 20 ++++++++++++++------
- 3 files changed, 33 insertions(+), 7 deletions(-)
-
-diff --git a/src/cpp/r/CMakeLists.txt b/src/cpp/r/CMakeLists.txt
-index 6984ae309c..29784b8b67 100644
---- a/src/cpp/r/CMakeLists.txt
-+++ b/src/cpp/r/CMakeLists.txt
-@@ -15,6 +15,18 @@
-
- project (R)
-
-+# find the version of R in play
-+find_package(LibR REQUIRED)
-+execute_process(
-+ COMMAND "${LIBR_EXECUTABLE}" "--vanilla" "--slave" "-e" "cat(as.character(getRversion()))"
-+ OUTPUT_VARIABLE LIBR_VERSION)
-+
-+# parse and save the R version to a variable
-+string(REPLACE "." ";" R_VERSION_LIST "${LIBR_VERSION}")
-+list(GET R_VERSION_LIST 0 R_VERSION_MAJOR)
-+list(GET R_VERSION_LIST 1 R_VERSION_MINOR)
-+list(GET R_VERSION_LIST 2 R_VERSION_PATCH)
-+
- # include files
- file(GLOB_RECURSE R_HEADER_FILES "*.h*")
-
-diff --git a/src/cpp/r/config.h.in b/src/cpp/r/config.h.in
-index 6ba67c8e09..00bc8b6191 100644
---- a/src/cpp/r/config.h.in
-+++ b/src/cpp/r/config.h.in
-@@ -1,7 +1,7 @@
- /*
- * config.h.in
- *
-- * Copyright (C) 2009-12 by RStudio, PBC
-+ * Copyright (C) 2009-20 by RStudio, Inc.
- *
- * Unless you have received this program directly from RStudio pursuant
- * to the terms of a commercial license agreement with RStudio, then
-@@ -16,4 +16,10 @@
-
- #cmakedefine PANGO_CAIRO_FOUND
-
-+// Important: These variables represent the version of R found during
-+// compile/link time, NOT the version of R present at runtime.
-+#define R_VERSION_MAJOR ${R_VERSION_MAJOR}
-+#define R_VERSION_MINOR ${R_VERSION_MINOR}
-+#define R_VERSION_PATCH ${R_VERSION_PATCH}
-+
-
-diff --git a/src/cpp/r/session/REmbeddedPosix.cpp b/src/cpp/r/session/REmbeddedPosix.cpp
-index ac71b94522..73e2e2ce7f 100644
---- a/src/cpp/r/session/REmbeddedPosix.cpp
-+++ b/src/cpp/r/session/REmbeddedPosix.cpp
-@@ -1,7 +1,7 @@
- /*
- * REmbeddedPosix.cpp
- *
-- * Copyright (C) 2009-19 by RStudio, PBC
-+ * Copyright (C) 2009-20 by RStudio, Inc.
- *
- * Unless you have received this program directly from RStudio pursuant
- * to the terms of a commercial license agreement with RStudio, then
-@@ -38,6 +38,8 @@ extern "C" void (*ptr_R_ProcessEvents)(void);
- extern "C" typedef void (*ptr_QuartzCocoa_SetupEventLoop)(int, unsigned long);
- #endif
-
-+#include "config.h"
-+
- extern int R_running_as_main_program; // from unix/system.c
-
- using namespace rstudio::core;
-@@ -103,14 +105,20 @@ void runEmbeddedR(const core::FilePath& /*rHome*/, // ignored on posix
- //
- structRstart rp;
- Rstart Rp = &rp;
-- R_DefParams(Rp) ;
-- Rp->R_Slave = FALSE ;
-+ R_DefParams(Rp);
-+#if R_VERSION_MAJOR > 3
-+ // R 4.0 and above use --no-echo to suppress output
-+ Rp->R_NoEcho = FALSE;
-+#else
-+ // R 3.x and below use --slave
-+ Rp->R_Slave = FALSE;
-+#endif
- Rp->R_Quiet = quiet ? TRUE : FALSE;
-- Rp->R_Interactive = TRUE ;
-- Rp->SaveAction = defaultSaveAction ;
-+ Rp->R_Interactive = TRUE;
-+ Rp->SaveAction = defaultSaveAction;
- Rp->RestoreAction = SA_NORESTORE; // handled within initialize()
- Rp->LoadInitFile = loadInitFile ? TRUE : FALSE;
-- R_SetParams(Rp) ;
-+ R_SetParams(Rp);
-
- // redirect console
- R_Interactive = TRUE; // should have also been set by call to Rf_initialize_R