summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-07-15 18:45:49 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-07-15 18:46:00 -0400
commitf7faea939cecd6b64d641b8e3d106b3e56b558c8 (patch)
treee2f2099250a1b18d5875aee9101549b00e7881b9 /sci-mathematics/singular/singular-4.3.1_p3.ebuild
parentdev-lang/luau: bump to 0.584 (diff)
downloadgentoo-f7faea939cecd6b64d641b8e3d106b3e56b558c8.tar.gz
gentoo-f7faea939cecd6b64d641b8e3d106b3e56b558c8.tar.bz2
gentoo-f7faea939cecd6b64d641b8e3d106b3e56b558c8.zip
sci-mathematics/singular: drop 4.3.1_p3
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/singular/singular-4.3.1_p3.ebuild')
-rw-r--r--sci-mathematics/singular/singular-4.3.1_p3.ebuild103
1 files changed, 0 insertions, 103 deletions
diff --git a/sci-mathematics/singular/singular-4.3.1_p3.ebuild b/sci-mathematics/singular/singular-4.3.1_p3.ebuild
deleted file mode 100644
index 5bb8ebd002a2..000000000000
--- a/sci-mathematics/singular/singular-4.3.1_p3.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-MY_PN=Singular
-MY_PV=$(ver_rs 3 '')
-# Consistency is different...
-MY_DIR2=$(ver_cut 1-3 ${PV})
-MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
-
-DESCRIPTION="Computer algebra system for polynomial computations"
-HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
-SRC_URI="https://www.singular.uni-kl.de/ftp/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_DIR2}"
-
-LICENSE="BSD GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~riscv ~x86 ~x86-linux"
-IUSE="emacs examples polymake +readline static-libs"
-
-RDEPEND="
- dev-lang/perl
- dev-libs/gmp:0
- dev-libs/ntl:=
- sci-libs/cddlib
- sci-mathematics/flint
- emacs? ( >=app-editors/emacs-23.1:* )
- polymake? ( sci-mathematics/polymake )
- readline? ( sys-libs/readline )
-"
-DEPEND="${RDEPEND}"
-
-SITEFILE=60${PN}-gentoo.el
-
-src_configure() {
- local myconf=(
- --disable-debug
- --disable-doc
- --disable-optimizationflags
- --disable-pyobject-module
- --disable-python
- --disable-python-module
- --disable-python_module
- --enable-factory
- --enable-gfanlib
- --enable-libfac
- --with-flint
- --with-gmp
- --with-libparse
- --with-ntl
- --without-python
- --without-pythonmodule
- $(use_enable emacs)
- $(use_enable polymake polymake-module)
- $(use_enable static-libs static)
- $(use_with readline)
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- pushd "${S}"/emacs
- elisp-compile *.el || die "elisp-compile failed"
- popd
- fi
-}
-
-src_install() {
- # Do not compress singular's info file (singular.hlp)
- # some consumer of that file do not know how to deal with compression
- docompress -x /usr/share/info
-
- default
-
- dosym Singular /usr/bin/"${PN}"
-
- # purge .la file
- find "${ED}" -name '*.la' -delete || die
-}
-
-src_test() {
- # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
- # an already installed version of singular may be used and cause segfault
- # See https://github.com/Singular/Sources/issues/980
- SINGULAR_PROCS_DIR="" emake check
-}
-
-pkg_postinst() {
- einfo "Additional functionality can be enabled by installing"
- einfo "sci-mathematics/4ti2"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}