summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-06-12 23:24:23 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-06-12 23:24:23 +0200
commitea162b812cb64c737eba031c8fcb8bbef7a2084a (patch)
tree8498f5a126fb20cb77655cf88accd4a0d9178296 /sci-mathematics/why3-for-spark/files
parentdev-libs/elfutils: bump up to 0.180 (diff)
downloadgentoo-ea162b812cb64c737eba031c8fcb8bbef7a2084a.tar.gz
gentoo-ea162b812cb64c737eba031c8fcb8bbef7a2084a.tar.bz2
gentoo-ea162b812cb64c737eba031c8fcb8bbef7a2084a.zip
sci-mathematics/why3-for-spark: fix flags and compression
Closes: https://bugs.gentoo.org/728032 Closes: https://bugs.gentoo.org/728050 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics/why3-for-spark/files')
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch
new file mode 100644
index 000000000000..b562bb02cd84
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2019-flags.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.in 2020-06-12 21:03:33.375534124 +0200
++++ b/Makefile.in 2020-06-12 21:03:48.623283408 +0200
+@@ -96,7 +96,7 @@
+
+ WARNINGS = A-4-9-41-44-45-50-52@5@8@48
+
+-OFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES)
++OFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES) -cclib "$(LDFLAGS)" -ccopt "$(CFLAGS)"
+ BFLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g $(INCLUDES)
+
+ OLINKFLAGS = -linkall $(EXTCMXA)
+@@ -664,13 +664,13 @@
+ all: $(TOOLS)
+
+ lib/why3server$(EXE): $(SERVER_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ lib/why3cpulimit$(EXE): $(CPULIM_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ %.o: %.c
+- $(CC) -Wall -O -g -o $@ -c $<
++ $(CC) -Wall -O -g $(CFLAGS) -o $@ -c $<
+
+ uninstall-bin::
+ rm -f $(LIBDIR)/why3/why3server$(EXE) $(LIBDIR)/why3/why3cpulimit$(EXE)