summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-04-09 01:26:02 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-04-09 01:26:02 +0600
commitf35c51a4e0f1b3afa4873c86dfa627bc607bb368 (patch)
tree7b8e203515f7dbb95b719ad88496248a542d928e /sci-mathematics/wxmaxima
parentdev-libs/grantlee: EAPI 6, update HOMEPAGE (diff)
downloadgentoo-f35c51a4e0f1b3afa4873c86dfa627bc607bb368.tar.gz
gentoo-f35c51a4e0f1b3afa4873c86dfa627bc607bb368.tar.bz2
gentoo-f35c51a4e0f1b3afa4873c86dfa627bc607bb368.zip
sci-mathematics/wxmaxima: bump to 16.04.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-16.04.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 15147d2999ce..d9230396f5bf 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxMaxima-13.04.2.tar.gz 1652680 SHA256 29352db75dd3ff27393ab0971543fd0b3c3a
DIST wxmaxima-15.04.0.tar.gz 4990313 SHA256 c178067a2f75d91dd378f88b4d0f87af6b2705ca32bea509d63e7347b2a1d21e SHA512 1a899259698da38f97a1859ba0526406cbc654a130dc1d18e01cf248ac4d7292c82cb00dd92ce2fac2c3cfc002788fdef0a6a4f95eca54b9096efc73c6aa45b7 WHIRLPOOL 225456c073b1aa87d2e599b9c63244ff7c97378fb6b5a60fcb8730655d193a0f032b27a1264e12eefb4abf08389f2337a11c380b6d89af2de9a4fb6e14f614dc
DIST wxmaxima-15.08.2.tar.gz 5592673 SHA256 7ad3f018e42d15d06bee5af10053edb72e441c1d1feee318dc6eb927db6a26c5 SHA512 a537c49477f54df4fd9e4e42a5e0d0d740f1ede817d807a98b7cec877a3ad77b2be0a61ae487a7fa5beb193b112eca163b8873292ecab5acf118d58a91e91af6 WHIRLPOOL a4df36704bbd33f841ddf3b9651662a092708850cdc637e6f6bfabc195c1e7e34dd66e14d92ee1cba69f3810bc74a4295837709d38bf6d6ce83b81d7776a3b9a
DIST wxmaxima-16.04.0.tar.gz 5177673 SHA256 d49cd1ff6bfccda13f766c9f712445d0c49008dfdfabe514759f5434676fe17e SHA512 5d1884b106528e0a4be18a734ac248287c86f691ea56399c38bef35c902440f0e0b66afd4f015d9c08f47435eb150bd2daac421cd0c65119adf8590337f12aee WHIRLPOOL 2dc2c14481937c3b0589ef8a4fba9b04340250d39e0f833ae0ff65f091b989bbea0254b574ce5ea75f0aeeab37d5864d27d10e26f5acc86dbd8faafe6652e2bc
+DIST wxmaxima-16.04.1.tar.gz 5177734 SHA256 907fecb2f5f0b5430eb9ade2ece8c41e4bdf73315c2484ffa4832ec47266b684 SHA512 4d24daf6d6df08d88b7c833d48bdaddc8d8a52cca357b8c940ceb3825122ed351f417780a81af1b41b3b014518b14efbb51d8e247bb228dc1e4f83d0fed79365 WHIRLPOOL a750935002ea0f4bb46cb7bc70c02cdf049adef20a351e9e4a93e53426e22fcab6292b31731531149d4e4e66897adee043d0d90046079723ad809d4ae6886750
diff --git a/sci-mathematics/wxmaxima/wxmaxima-16.04.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-16.04.1.ebuild
new file mode 100644
index 000000000000..1e052291633c
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-16.04.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ local i
+
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in test/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Dirstructure.cpp src/Dirstructure.h \
+ || die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+ default
+ doicon -s 128 data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}