summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-09 10:12:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-09 11:30:07 +0200
commit06021461187e64c3e51d48b0a9edde50d1f591c6 (patch)
tree80d0eed442435b4b8951ecc34aa5f869dc9eaab5 /sci-mathematics
parentsci-mathematics/boolector: drop old 3.2.2_p20220110 (diff)
downloadgentoo-06021461187e64c3e51d48b0a9edde50d1f591c6.tar.gz
gentoo-06021461187e64c3e51d48b0a9edde50d1f591c6.tar.bz2
gentoo-06021461187e64c3e51d48b0a9edde50d1f591c6.zip
sci-mathematics/boolector: fix install on musl
Closes: https://bugs.gentoo.org/928977 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/boolector/boolector-3.2.3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-mathematics/boolector/boolector-3.2.3.ebuild b/sci-mathematics/boolector/boolector-3.2.3.ebuild
index 1497adc7c225..6b8f8f0d0d56 100644
--- a/sci-mathematics/boolector/boolector-3.2.3.ebuild
+++ b/sci-mathematics/boolector/boolector-3.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -75,10 +75,12 @@ src_configure() {
src_install() {
cmake_src_install
- dodir "/usr/$(get_libdir)"
- mv "${ED}/usr/lib"/*.so "${ED}/usr/$(get_libdir)/" || die
-
if use examples ; then
dodoc -r examples
fi
+
+ if [[ "$(get_libdir)" != lib ]] ; then
+ dodir "/usr/$(get_libdir)"
+ mv "${ED}/usr/lib"/*.so "${ED}/usr/$(get_libdir)/" || die
+ fi
}