summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-07-02 12:17:49 +1200
committerMichael Orlitzky <mjo@gentoo.org>2021-07-01 20:42:13 -0400
commit0f67609cac00b0e0009925a651d2486f0ed61d34 (patch)
tree3043b89eca0a42c9003f2d8749df52dadd3888e3 /sci-mathematics
parentsci-mathematics/singular: fix the doc-install patch (diff)
downloadgentoo-0f67609cac00b0e0009925a651d2486f0ed61d34.tar.gz
gentoo-0f67609cac00b0e0009925a651d2486f0ed61d34.tar.bz2
gentoo-0f67609cac00b0e0009925a651d2486f0ed61d34.zip
sci-mathematics/singular: better flag control to avoid segfault
Closes: https://bugs.gentoo.org/797655 Closes: https://github.com/gentoo/gentoo/pull/21381 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/singular/singular-4.2.0_p3-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-mathematics/singular/singular-4.2.0_p3-r1.ebuild b/sci-mathematics/singular/singular-4.2.0_p3-r1.ebuild
index dd0a6b83be08..7e20b068308c 100644
--- a/sci-mathematics/singular/singular-4.2.0_p3-r1.ebuild
+++ b/sci-mathematics/singular/singular-4.2.0_p3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools elisp-common
+inherit autotools elisp-common flag-o-matic
MY_PN=Singular
MY_PV=$(ver_rs 3 '')
@@ -47,6 +47,9 @@ src_prepare() {
}
src_configure() {
+ # singular may segfault with common optimisation such as -O2 without this flag
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
econf --with-gmp \
--with-ntl \
--with-flint \
@@ -57,6 +60,7 @@ src_configure() {
--enable-libfac \
--disable-polymake \
--with-libparse \
+ --disable-optimizationflags \
$(use_enable static-libs static) \
$(use_enable emacs) \
$(use_with readline)