summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-01-29 17:49:38 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-01-29 20:00:49 -0500
commit153d3a3b7e4da128e6214308868c666c3d62e173 (patch)
treeaf1f7a247734119d5e76c1f8f7539c5967ea5941 /sci-mathematics
parentdev-python/unicodecsv-0.14.1-r1: add py38 (diff)
downloadgentoo-153d3a3b7e4da128e6214308868c666c3d62e173.tar.gz
gentoo-153d3a3b7e4da128e6214308868c666c3d62e173.tar.bz2
gentoo-153d3a3b7e4da128e6214308868c666c3d62e173.zip
sci-mathematics/planarity: new package of graph planarity algorithms.
This commit imports the "planarity" package from the sage-on-gentoo overlay with a few minor changes: * Update to EAPI=7. * Drop autotools.eclass and use the tarball from sagemath.org that contains the autotools stuff. * Add USE=examples to install some sample input/output. * Update the old code.google.com HOMEPAGE to point to github. The SageMath project now has the ability to detect and use a system copy of planarity, so this will help Gentoo users of SageMath avoid some pointless rebuilds of planarity. Closes: https://bugs.gentoo.org/707324 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/planarity/Manifest1
-rw-r--r--sci-mathematics/planarity/files/planarity-3.0.0.5-extern.patch21
-rw-r--r--sci-mathematics/planarity/metadata.xml26
-rw-r--r--sci-mathematics/planarity/planarity-3.0.0.5.ebuild33
4 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/planarity/Manifest b/sci-mathematics/planarity/Manifest
new file mode 100644
index 000000000000..18c3677165af
--- /dev/null
+++ b/sci-mathematics/planarity/Manifest
@@ -0,0 +1 @@
+DIST planarity-3.0.0.5.tar.gz 492644 BLAKE2B d183bc07cab7246b62cc7340956206e3f6c5999aa92b223e7665ebd8ae1bc0c354011c078ea4f42d2e45efa2ae5e83e082e4c8d80e3391a4f20be1020ebf8188 SHA512 dfeb7e024e1f5758e5abbd854c4ca963b4f5d45433b2c5eb00ce85c154b5407ebccd1ace0db167488dee757db2c23367101a2aa568941a3664bac9058ea24328
diff --git a/sci-mathematics/planarity/files/planarity-3.0.0.5-extern.patch b/sci-mathematics/planarity/files/planarity-3.0.0.5-extern.patch
new file mode 100644
index 000000000000..c1b2a27e55c6
--- /dev/null
+++ b/sci-mathematics/planarity/files/planarity-3.0.0.5-extern.patch
@@ -0,0 +1,21 @@
+diff -Naur planarity-2.2.0.orig/c/planarity.h planarity-2.2.0/c/planarity.h
+--- planarity-2.2.0.orig/c/planarity.h 2015-06-04 22:24:57.753965370 +1200
++++ planarity-2.2.0/c/planarity.h 2015-06-04 23:02:38.138973933 +1200
+@@ -77,7 +77,7 @@
+ int legacyCommandLine(int argc, char *argv[]);
+ int menu();
+
+-char Mode,
++extern char Mode,
+ OrigOut,
+ EmbeddableOut,
+ ObstructedOut,
+@@ -88,7 +88,7 @@
+
+ /* Low-level Utilities */
+ #define MAXLINE 1024
+-char Line[MAXLINE];
++extern char Line[MAXLINE];
+
+ void Message(char *message);
+ void ErrorMessage(char *message);
diff --git a/sci-mathematics/planarity/metadata.xml b/sci-mathematics/planarity/metadata.xml
new file mode 100644
index 000000000000..d6f3a10ad530
--- /dev/null
+++ b/sci-mathematics/planarity/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">
+ graph-algorithms/edge-addition-planarity-suite
+ </remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/planarity/planarity-3.0.0.5.ebuild b/sci-mathematics/planarity/planarity-3.0.0.5.ebuild
new file mode 100644
index 000000000000..2deb388db702
--- /dev/null
+++ b/sci-mathematics/planarity/planarity-3.0.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="edge-addition-planarity-suite-Version"
+DESCRIPTION="The edge addition planarity suite of graph algorithms"
+HOMEPAGE="https://github.com/graph-algorithms/edge-addition-planarity-suite/"
+
+# Use the tarball from sage because the github release doesn't
+# contain the generated autotools files (like ./configure).
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+IUSE="examples static-libs"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# https://github.com/graph-algorithms/edge-addition-planarity-suite/issues/4
+# https://github.com/graph-algorithms/edge-addition-planarity-suite/pull/3
+PATCHES=( "${FILESDIR}/${P}-extern.patch" )
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+ use examples && dodoc -r c/samples
+}