summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:24:41 +0100
committerSam James <sam@gentoo.org>2021-04-02 15:04:30 +0100
commit1d465356d23e625a0c9494f22bca184745b904ad (patch)
tree6413e35bab760d3f1e4aeb30f6fd1bbfb04032aa /sci-mathematics
parentgames-puzzle/pipepanic: fix RDEPEND typo (diff)
downloadgentoo-1d465356d23e625a0c9494f22bca184745b904ad.tar.gz
gentoo-1d465356d23e625a0c9494f22bca184745b904ad.tar.bz2
gentoo-1d465356d23e625a0c9494f22bca184745b904ad.zip
sci-mathematics/flint: fix CMAKE_MAKEFILE_GENERATOR
Controls sys-devel/make dependency in global scope, hence must be defined pre-inherit. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flint/flint-2.7.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sci-mathematics/flint/flint-2.7.1.ebuild b/sci-mathematics/flint/flint-2.7.1.ebuild
index 6557576cf7d8..92eb4e95a2c2 100644
--- a/sci-mathematics/flint/flint-2.7.1.ebuild
+++ b/sci-mathematics/flint/flint-2.7.1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+# ninja doesn't like "-lcblas" so using make.
+CMAKE_MAKEFILE_GENERATOR="emake"
PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-any-r1
@@ -34,9 +36,6 @@ DEPEND="dev-libs/gmp:=
virtual/cblas"
RDEPEND="${DEPEND}"
-# ninja doesn't like "-lcblas" so using make.
-CMAKE_MAKEFILE_GENERATOR="emake"
-
src_configure() {
local mycmakeargs=(
-DWITH_NTL="$(usex ntl)"