summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-16 00:41:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-16 00:41:47 +1000
commit32f938552ffece338b55fb5cb672a2bd47c85d98 (patch)
tree937e91e8bc58db288587f8f94f387245c0bfad61 /sci-mathematics
parentapp-i18n/skk-jisyo: fix build with dev-db/cdb (diff)
downloadgentoo-32f938552ffece338b55fb5cb672a2bd47c85d98.tar.gz
gentoo-32f938552ffece338b55fb5cb672a2bd47c85d98.tar.bz2
gentoo-32f938552ffece338b55fb5cb672a2bd47c85d98.zip
sci-mathematics/rkward: version bump
Gentoo-bug: 587962 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rkward/Manifest1
-rw-r--r--sci-mathematics/rkward/rkward-0.6.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/Manifest b/sci-mathematics/rkward/Manifest
index 46d3c9999420..0b48010bdbaa 100644
--- a/sci-mathematics/rkward/Manifest
+++ b/sci-mathematics/rkward/Manifest
@@ -1 +1,2 @@
DIST rkward-0.6.1.tar.gz 1529612 SHA256 7887bc22645a8e6de278da55e31a61acd91aca0ade777af11a110d0dfcfffde7 SHA512 5171b60ed42049de9e0f45b64f61a9bcf1fe8ba89e5a5a8b9ba77b9f7adb0d61630691adcb6636f5d5c5023c64a48220e85ea93c2ea09af34df2fa4be5d0cc9f WHIRLPOOL 2b195384dc0e093b445f7bf21c1f4bc2f378af7e51adb20f046a97e07d7f808b04eb3be9a35198b389b84edc79b3936d2f3d5e7eebc82ff3bb612465b813bcb3
+DIST rkward-0.6.5.tar.gz 3731011 SHA256 3fc5acb48ce717dee8fbbe32973ea4c61f30c335bd18a75471142b19b436a032 SHA512 7ea5016a0bc5bb6ed24e38252338142e32291aaff547dce9c3f61524b60395ce595803aa059580e56c38ed9600d09647acb2a8feb060819a0436475e4bf6f1b6 WHIRLPOOL d7dedc8cb1f65c124ea3d2a3f52c557477d3ce472c33a40df7e0c905d2ee18713dfe7980756058fc62d576661b26db4312f5ce0da017fac13477c670ea238904
diff --git a/sci-mathematics/rkward/rkward-0.6.5.ebuild b/sci-mathematics/rkward/rkward-0.6.5.ebuild
new file mode 100644
index 000000000000..0b74fdab4dd1
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+WEBKIT_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="https://rkward.kde.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep katepart)
+ dev-lang/R
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # to have it compatible with R which had a bad R_HOME
+ unset R_HOME
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ # avoid file collision with kate
+ rm "${ED}"/usr/share/apps/katepart/syntax/r.xml || die
+}