summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-06-30 11:13:51 +1200
committerMichael Orlitzky <mjo@gentoo.org>2021-07-01 15:27:50 -0400
commit3b956f31ab918165ac77b5a918d17c54419a7de2 (patch)
treefbf023e981b7120bceeff30db3b4796ceefdba08 /sci-mathematics
parentdev-php/PHPMailer: remove vulnerable PHPMailer-6.4.1.ebuild. (diff)
downloadgentoo-3b956f31ab918165ac77b5a918d17c54419a7de2.tar.gz
gentoo-3b956f31ab918165ac77b5a918d17c54419a7de2.tar.bz2
gentoo-3b956f31ab918165ac77b5a918d17c54419a7de2.zip
sci-mathematics/eclib: new upstream release
Closes: https://github.com/gentoo/gentoo/pull/21480 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20210625.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 50866b965f5a..825ef55d4696 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,2 +1,3 @@
DIST eclib-20190909.tar.bz2 914900 BLAKE2B df57972792f96e65b25db5a2ab1063d5a8f1ad05edbed77d9ca2632ddfb4af2cb8586e572155beec09cc0c03472300d1e6fcbdda3527c36e9106006239f50600 SHA512 df829b10c353f528f2040b55d6198e3a48eba179b9a80e71794e4c6d46ee9bb13b3eccec15c7d286ec5d8252e6ba91157c2a08ac4e2da86969a4158450a41960
DIST eclib-20210503.tar.bz2 920919 BLAKE2B 5481769d6e9152d85f69a15d856701b5faf0b2d7d8c5fd0e2b6452d7be1f5de23ec2c3f60603d87e4d95f25295ef2a2f44dacf5c844c6970e96a83cd61bdfe66 SHA512 a3ee992d97c00ec5069a090d19914b9e1d00b25f5f1fff1ccd02deb1d240e4773bcfe0e00366808b7afe3a24e0aed8bb2fc4e9cb4f9f97dfc6ef70c43362bd38
+DIST eclib-20210625.tar.bz2 921173 BLAKE2B 8ecfde35fd6e557601c0a4e5f877ec49e355dbd5bb4248256c89b1160406992f59568db1060a835bad482d6ba4f1f0cc7719af5f03ecdc79abbe2ca0c9ed713e SHA512 a1319e91790decbc5219e02edbad5b86a6d3e5400bec3a9a9f2c60b89d340a0b915458f93c86f63d21c4b72995aa5fe65e0b5346241f297fe54ba2d3fc183ae3
diff --git a/sci-mathematics/eclib/eclib-20210625.ebuild b/sci-mathematics/eclib/eclib-20210625.ebuild
new file mode 100644
index 000000000000..64c4360ac565
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20210625.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}