summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-19 12:00:35 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-19 13:26:30 -0500
commit40a535162ec3b07a9db49dec148bef7026a67875 (patch)
treed3138f0d4df93cf0f486418b766599f1d881b3fd /sci-mathematics
parentdev-util/b2: add 4.10.0 (diff)
downloadgentoo-40a535162ec3b07a9db49dec148bef7026a67875.tar.gz
gentoo-40a535162ec3b07a9db49dec148bef7026a67875.tar.bz2
gentoo-40a535162ec3b07a9db49dec148bef7026a67875.zip
sci-mathematics/cgal: add 5.5.2
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cgal/Manifest2
-rw-r--r--sci-mathematics/cgal/cgal-5.5.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
index 266d17d8ebf4..f5968708d127 100644
--- a/sci-mathematics/cgal/Manifest
+++ b/sci-mathematics/cgal/Manifest
@@ -1,2 +1,4 @@
DIST CGAL-5.5-doc_html.tar.xz 53145672 BLAKE2B 7a575f09eed2fd97f3e68f37428d4ab41c267a6e4c158e653a8c2b5a17f2c56a31b64937fa161d3f256b473a1e617acbce2f3bfb71c2e810b8b0335b57a8b54c SHA512 41e16b44b93664ddd5185358165cce99f149fa33bdb308ce7230550ee79e3603c24df5b8d4f67de324ebf7e8a8c1e343e6d76341464cedd9d9af50f5d512af3b
+DIST CGAL-5.5.2-doc_html.tar.xz 53155520 BLAKE2B 349f4dd2a5821412a614c6aa6c20bc3da24f23341b286d0d4eff0546a5decb9e4d13a8b53cd41a4431a710e2dfa54594997d4075bed548538b5590b1d375a363 SHA512 7b98462e32d29553bdc11e435ba086c81a9cf7506b9ad8d118de8cb8d689d3647c7956164e81b8b02768990f7cc0661e6cdc1eea0ac01d55a87b95e4c9248791
+DIST CGAL-5.5.2.tar.xz 24159628 BLAKE2B 23417651deba4fa1587ee3082483672f7f8864621ceb8ef273d2ab0490bb7fe0dc96358393d39d33b14c50c5bde4d2138b8982fa3907a049151d12e7cbc3c4f8 SHA512 2842b027f68d98be5b747bbf1c5fa9310b82247520f1dc90b7612311a77aad83f519805a366317c4d50ca440dc604be6b7ca88160add1ce2b8006f0e561363eb
DIST CGAL-5.5.tar.xz 24156768 BLAKE2B e5f02cd082abfa8443e65430ed366cfdc3736c6a7af37284969ddd558ede1aa6c881d6928c65708504fd58f68ea01f56aa0749267d6dc83fd54f0b28e8c01374 SHA512 7fa6bf6c046727a9e0bce7cbde34cbe85979127a1ad0904f2865be83a80e89fa9af5118e5647572414f8096d29ecc808ee471d4bd3e7ecd41338be649b549290
diff --git a/sci-mathematics/cgal/cgal-5.5.2.ebuild b/sci-mathematics/cgal/cgal-5.5.2.ebuild
new file mode 100644
index 000000000000..d1309dbac6e5
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-5.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Modules provided by dev-cpp/eigen
+CMAKE_REMOVE_MODULES_LIST=( FindEigen3 )
+inherit cmake
+
+MY_P=CGAL-${PV}
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="https://www.cgal.org/"
+SRC_URI="
+ https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}.tar.xz
+ doc? ( https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}-doc_html.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0/14"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/boost:=
+ dev-libs/gmp:=[cxx]
+ dev-libs/mpfr:=
+ sys-libs/zlib
+ x11-libs/libX11:=
+ virtual/glu:=
+ virtual/opengl:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.11.1-fix-buildsystem.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR="$(get_libdir)"
+ -DCGAL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/CGAL"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+
+ cmake_src_install
+
+ if use examples; then
+ dodoc -r examples demo
+ fi
+}