summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-15 21:19:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-15 22:20:41 +0100
commit49552e9fcd8f04cd3dde80b7935490ac3022d434 (patch)
tree0297eb57d49211dedc7de000cbbfb0170731e2ba /sci-mathematics
parentsci-mathematics/gappa: bump to 1.4.2 (diff)
downloadgentoo-49552e9fcd8f04cd3dde80b7935490ac3022d434.tar.gz
gentoo-49552e9fcd8f04cd3dde80b7935490ac3022d434.tar.bz2
gentoo-49552e9fcd8f04cd3dde80b7935490ac3022d434.zip
sci-mathematics/eprover: bump to 3.0.03
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eprover/Manifest1
-rw-r--r--sci-mathematics/eprover/eprover-3.0.03.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/eprover/Manifest b/sci-mathematics/eprover/Manifest
index 900895cc225b..bc8c790512c4 100644
--- a/sci-mathematics/eprover/Manifest
+++ b/sci-mathematics/eprover/Manifest
@@ -1 +1,2 @@
+DIST eprover-3.0.03.tar.gz 1523036 BLAKE2B fc58b4f99b4fcd8ef4b0704c6fb65e7ef235582d8e2cdef17fd178ec51b7655459dbbf9d0d20ef00edf15f893aefdd4dd07c7fe402e42a5378b4bf241af6c806 SHA512 3adce986eb0d6d6b8373b10d8104ca2a68c72c92cd5c8cb7416044b1ae67daa0b8da82c13e85129d0699217b26a98df15768a5b0dca927ab26920a26dbba9662
DIST eprover-3.0_pre008.tar.gz 1512310 BLAKE2B 88533bd05b823155639df49d631f4fb339019f624ea6cb1c3c7c46f1db331183dac4285c70a7efa372cbf3f0e839ec41b7589b93e4599a6ed94f42734f361985 SHA512 81f1a1dfd77b685805c80f95b683489d8759acbb5b45ebaf123f1b0f7cb82f9e2d58731975e5286afa9a8bf9d2874cc5362edc0c0da92aea39830ac4b8b1c4ec
diff --git a/sci-mathematics/eprover/eprover-3.0.03.ebuild b/sci-mathematics/eprover/eprover-3.0.03.ebuild
new file mode 100644
index 000000000000..ef6b9196aa7d
--- /dev/null
+++ b/sci-mathematics/eprover/eprover-3.0.03.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automated theorem prover for full first-order logic with equality"
+HOMEPAGE="https://www.eprover.org/
+ https://github.com/eprover/eprover/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/eprover/${PN}.git"
+else
+ SRC_URI="https://github.com/eprover/${PN}/archive/E-${PV/_/}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-E-${PV/_/}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+ho"
+
+BDEPEND="
+ sys-apps/help2man
+"
+
+src_prepare() {
+ default
+
+ sed -e "/^OPTFLAGS/s|= .*|= ${CFLAGS}|" \
+ -e "/^LD/s|= .*|= $(tc-getCC) ${LDFLAGS}|" \
+ -e "/^ AR/s|ar|$(tc-getAR)|" \
+ -e "/^ CC/s|gcc|$(tc-getCC)|" \
+ -i "${S}/Makefile.vars" || die
+
+ sed -e "s|ar rc|$(tc-getAR) rc|g" \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ -i "${S}/CONTRIB/picosat-965/makefile.in" || die
+}
+
+src_configure() {
+ local -a myconf=(
+ $(usex ho '--enable-ho' '')
+ --bindir=/usr/bin
+ --exec-prefix=/usr
+ --man-prefix=/usr/share/man/man1
+ )
+ sh ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+ default
+
+ if use ho ; then
+ ln -s "${S}/PROVER/${PN}-ho" "${S}/PROVER/${PN}" || die
+ fi
+
+ emake man
+}
+
+src_install() {
+ # Picosat (CONTRIB package) is available as separate package.
+ rm -r "${S}/CONTRIB" || die
+
+ emake EXECPATH="${ED}/usr/bin" MANPATH="${ED}/usr/share/man/man1" install
+ dodoc -r DOC EXAMPLE_PROBLEMS
+
+ if use ho ; then
+ dosym -r "/usr/bin/${PN}-ho" "/usr/bin/${PN}"
+ fi
+}