summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-03-18 17:06:56 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-03-18 17:07:54 +0600
commit4a1dff9398711407590429262674093a5d621de1 (patch)
treee9d4670bf78f8a043c3f4cdde66514b8f8c55522 /sci-mathematics
parentmail-client/trojita: introduce crypt USE flag (diff)
downloadgentoo-4a1dff9398711407590429262674093a5d621de1.tar.gz
gentoo-4a1dff9398711407590429262674093a5d621de1.tar.bz2
gentoo-4a1dff9398711407590429262674093a5d621de1.zip
sci-mathematics/maxima: fix elisp files compilation
Bug: 576652 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/maxima-5.37.3-r4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/maxima/maxima-5.37.3-r4.ebuild b/sci-mathematics/maxima/maxima-5.37.3-r4.ebuild
index 06cbc93faa03..fea3dd575f7d 100644
--- a/sci-mathematics/maxima/maxima-5.37.3-r4.ebuild
+++ b/sci-mathematics/maxima/maxima-5.37.3-r4.ebuild
@@ -147,7 +147,15 @@ src_configure() {
src_compile() {
emake
- use emacs && elisp-compile interfaces/emacs/{emaxima,imaxima}/*.el
+ if use emacs; then
+ pushd interfaces/emacs/emaxima > /dev/null
+ elisp-compile *.el
+ popd > /dev/null
+ pushd interfaces/emacs/imaxima > /dev/null
+ BYTECOMPFLAGS="-L . -L ../emaxima"
+ elisp-compile *.el
+ popd > /dev/null
+ fi
}
src_install() {