summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-12-15 12:42:20 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-12-15 12:42:20 +0700
commit574d8ef28dc5f9b52bba13e3c8716fc525240299 (patch)
tree6af5ac7db9950873c02df5c10583e3152a131d5e /sci-mathematics
parentapp-text/podofo: add 0.10.3, drop 0.10.2 (diff)
downloadgentoo-574d8ef28dc5f9b52bba13e3c8716fc525240299.tar.gz
gentoo-574d8ef28dc5f9b52bba13e3c8716fc525240299.tar.bz2
gentoo-574d8ef28dc5f9b52bba13e3c8716fc525240299.zip
sci-mathematics/wxmaxima: bump to 23.11.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-23.11.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index d691c6e569cb..b8692b2dddf3 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxmaxima-23.04.1.tar.gz 22060726 BLAKE2B 77583c2461f7c32ac53ad2890d1e7d07a9
DIST wxmaxima-23.07.0.tar.gz 16427247 BLAKE2B c754e476adcf71b2074e5d20edc14ac0d81f453d2cfc1f69fb281c0e3290cf31487ee2772624f868bb1057c19e1dac3cee6bd402d2b7e8b35f1ef8e80c7611f5 SHA512 0b94443b2fa31c7f75f33d57285c5086e69f43abd53d2a66b78d946d5370982b5b3a2a53fc5c4b4631fec94453b6f94a209d7ba3d13b1518dbe597d62b7e4690
DIST wxmaxima-23.08.0.tar.gz 16425869 BLAKE2B cdfb8f9d376ef8cce7617f81678840ab812ad5f9ea6e37bc64e89f117402f5d1a93b03366263d314deecfe21bf56c28b212e91d5f8c79939354e8586a4d001cb SHA512 3db91ade52879d90ededfa48667e6f6f5895dad4f34fbe5896c631fe12cc9b95b631d9a26cbf847a9b3578f40a25242d42a8efbbf856c0e47364404a21e8693f
DIST wxmaxima-23.10.0.tar.gz 16466027 BLAKE2B 496765bfe55efb168396530eb3c44ef727f0398bf30a32e9a869c48572f0b53b6d851a7d8aa421199c071791efec37dece6cc23901826c62ca7ab6715a27b0cc SHA512 4055595f8e294726d2731da4a926844d3ad25561bb7d392c0ef08eb9322bc7e454edb6ae137eb7b8c2be53aba2f36abb0a0b32e03af4cc9a517130fd5466a1fb
+DIST wxmaxima-23.11.0.tar.gz 16476485 BLAKE2B 1d5f5a516ba13c402837c995dac898a8b3fd85fa8e85a18f362ead4e737dff0cdc5d45754a1adeafabb19e504ca8a485ecd151049a76ff112721cebdf4a00941 SHA512 ee4fcff394913979c31b8060fb4ad0d32f5588bbdfe587f29d7528164bc9b31b2c24028dfa7f9deda1a984de12e15a4bbe94b265b9d528202a65f87c46d4352f
diff --git a/sci-mathematics/wxmaxima/wxmaxima-23.11.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-23.11.0.ebuild
new file mode 100644
index 000000000000..6b29481f6c3e
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-23.11.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}